250-AUTH missing from telnet test

Discussion in 'HOWTO-Related Questions' started by g8rbait, Nov 16, 2005.

  1. g8rbait

    g8rbait New Member

    After following the FC4 Perfect Setup Howto today, I ran the command telnet localhost 25 and then the ehlo localhost command. I received the 250-STARTTLS response along with several other 250 responses, but did not get the 250-AUTH response. Will this cause me problems?

    I have checked the main.cf file and all of the lines that were configured using the postconf -e command are present and correct.

    > Ooops, I was wrong. I found the following typo: "smtpd_sasl_auth_enabled = yes" when it should have read "smtpd_sasl_auth_enable = yes" Made that change and restarted the computer. Tried the Telnet localhost 25 command again and now I get the following message:

    Connected to localhost.localdomain (
    Escape Character is '^]'.
    Connection closed by foreign host.


    Last edited: Nov 16, 2005
  2. falko

    falko Super Moderator Howtoforge Staff

    So you don't see any 250 lines at all? Make sure that myhostname/mydomain in /etc/postfix/main.cf exist in DNS!
  3. g8rbait

    g8rbait New Member

    No, I didn't see any 250 lines. So, I went into the main.cf file and erased everything that I had configured using the postconf -e command and then started that section over. Second time around seemed to work really well.

    Also, since I did all this before you replyed to me, Falko, I don't know if the fix you suggested was what I needed to do or not.

    But one thing I will say is that I have acquired more Linux experience in the last week than I have in the last 12 years. I can see a lot of similarities to the M$ world, but I'm really beginning to like Linux more the more I play with it. Just wish I would have started using it years ago. So, I'll say thank you for your Howtoforge website and all the help you give to those of us who are Linux illiterate.

  4. attibv

    attibv New Member

    I followed the instruction from ISP-Server Setup - Ubuntu 5.10 "Breezy Badger and everything worked fine, except the Postfix install/config (i think). When I telnet the server on port 25 i don't see any 250-AUTH lines only the following:

    250-SIZE 10240000
    250 8BITMIME

    Could you tell me where am I wrong?

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you restarted postfix after the configuration?

    /etc/init.d/postfix restart

    If this wont help, please post the content of the file /etc/postfix/main.cf
  6. attibv

    attibv New Member

    Yes, I have restarted postfix.

    Here is the main.cf and I would like to mention that I had neither the 'myorigin = /etc/mailname' line. I have add it after the install and created the file also.

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h 
    myhostname = lp070011
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = lp070011, localhost.localdomain, localhost
    relayhost = 
    mynetworks =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enabled = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restriction = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    mailbox_command = procmail -a "$EXTENSION" 
  7. falko

    falko Super Moderator Howtoforge Staff

    Are you sure you telnet'ed the right server?
    If yes, you should re-run the Postfix and saslauthd configuration and make sure to avoid typos.

Share This Page