[Access denied for user 'ispconfig'@'localhost' (using password: YES)]

Discussion in 'Installation/Configuration' started by Salih Shihab, Jun 5, 2016.

  1. Salih Shihab

    Salih Shihab New Member

    Dear All
    I am new member here, I am using ispconfig 3, I face some problem with connect ftp server, for ftp client i use Filezila, the diagnoses I do:
    • the pure ftp is running and 21 is open and listing
    • when I went through syslog file I found this
    [ERROR] The SQL server seems to be down [Access denied for user 'ispconfig'@'localhost' (using password: YES)]
    May 30 12:13:11 web pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    May 30 12:13:16 web pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [asdfghj]
    so I relaize that the the password of ispconfig database user has changed, now I need help:
    How can I reset the password of ispconfig database user
    Many thanks
  2. Salih Shihab

    Salih Shihab New Member

    Hi all I solved the problem, first I found that the ispconfig user is gone, I do not know how but I will figure it out, so simply I add the ispconfig user again and the password that I gave to the user I took it from "/usr/local/ispconfig/server/lib/classes/db_mysql.inc.php" -->$conf['db_password'] = 'longstring';
    the steps are:
    • mysql -u root -p
    • create user 'ispconfig'@'localhost' IDENTIFIED BY 'longstring';
    • grant all on dbispconfig.* to 'ispconfig'@'localhost';
    try to connect ftp server and it works :)
    Fred66 likes this.
  3. Fred66

    Fred66 New Member

    Hi Salih !
    Big thanks for this tutorial, i have a similar bug here :)
    But... i dont understand the 'longstring'

    In my db_mysql.inc.php i have:
    Can you explain to me ?
    Many thanks ;)
  4. HansDinges

    HansDinges New Member HowtoForge Supporter

    Thank you.. worked for me! ;)
  5. Chris_UK

    Chris_UK Active Member HowtoForge Supporter

    Semi-Ancient post but in 3.1.12 (not sure how far back this is the case)
    nano /usr/local/ispconfig/interface/lib/config.inc.php
    You will find the password here (ubuntu).

Share This Page