Access denied for user 'ispconfig'@'localhost' (using password: YES)

Discussion in 'Installation/Configuration' started by ustoopia, Feb 27, 2023.

  1. ustoopia

    ustoopia Member

    Hi all,
    I'm experiencing a strange issue that I haven't been able to tackle. Whenever I do a 'systemctl status mysql" I see the following messages:

    [Warning] Access denied for user 'ispconfig'@'localhost' (using password: YES)
    [Warning] Aborted connection 624 to db: 'unconnected' user: 'unauthenticated' host: 'localhost' (This connection closed normally>
    [Warning] Aborted connection 625 to db: 'unconnected' user: 'unauthenticated' host: 'localhost' (This connection closed normally>
    etc

    I have no idea if these messages are related to one and other. The messages are spammed every so many seconds. I'm very curious what causes these messages. The thing is, everything seems to be functioning just fine! I can add websites and databases in ispconfig just fine. I should mention that I installed ISPconfig on this server using the auto install script, but something went wrong, so I used the uninstall command to remove ispconfig. After that I installed it again. I suspect that this somehow has caused these messages.
    I have confirmed that the password stored in /usr/local/ispconfig/server/lib/config.inc.php is the same one that was given to me at the end of the auto install script.

    Can somebody help me to shed a light on what's going on here? Or where I should start troubleshooting this issue.
    Thanks in advance!
     
    Last edited: Feb 27, 2023
  2. remkoh

    remkoh Active Member

    I guess every 60 seconds? That's how often ISPConfig's cronjobs run.

    Start by looking in your mysql if the user ispconfig exists and has access to dbispconfig through localhost.
     
  3. ustoopia

    ustoopia Member

    Yep! Every minute or so. From the commandline I can log in with user ispconfig using the password that I found in /usr/local/ispconfig/interface/lib/config.inc.php. I can also access the ispconfig db.
     

    Attached Files:

  4. remkoh

    remkoh Active Member

    Strange. It seems to be ISPConfig cron related to me.

    Do you have a single or multi server enviroment?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has two config files, the cronjob uses this one: /usr/local/ispconfig/server/lib/config.inc.php
     
  6. ustoopia

    ustoopia Member

    I think I solved the issue! As I was inspecting the file that Till just mentioned, I noticed that the database mentioned there was not the same as the actual dbispconfig. I corrected it and I no longer see the error messages from mariadb. Sorry for the hassle guys, but thank you again for the support!
     
    remkoh and till like this.
  7. ustoopia

    ustoopia Member

    Forget my previous post. I was doing that on completely the wrong machine. So dumb... That was not the issue.

    So the issue is still there. And the errors are a lot more often as just once per minute, by the way. See the image attachment.
    Also, I never saw the messages that I posted in my original post. (Aborted connection 634 to db: 'unconnected' user: 'unauthenticated' host: 'localhost' (This connection closed normally without a>).
    The folder /var/log/mysql is empty. Not sure if that can somehow be related...

    Still, everything seems to be working just fine! I'm running a single server setup.
     

    Attached Files:

  8. ustoopia

    ustoopia Member

    It looks like the error messages are a lot less frequent when I stop the Monit process. For a few moments I was under the impression that stopping Monit actually resolved my issue but it's still there. The error messages appear EXACTLY every 2 minutes now. With Monit disabled, what else can be causing these error messages?

    Another update! I stopped Postfix. Now the error messages have stopped. So my culprits are monit and postfix. I think I'll be able to figure the rest out from here on.

    So, what did I learn from this issue? If you are going to use the auto-install script a second time on the same machine, make sure that you clean up all the files that got installed the first time. The installer apparently doesn't update these files if it finds these files already there.
     
    Last edited: Feb 27, 2023
    remkoh likes this.

Share This Page