Accidently deleted database

Discussion in 'General' started by Dennis, Jun 22, 2008.

  1. Dennis

    Dennis New Member

    [Solved] Accidently deleted database

    I accidently deleted the database web5db6. I tried to delete all traces to this database by deleting another entry in ips_nodes and resetting the auto_increments.

    I was able to create a database with the same name again, but when I go to the site' s options tab in ispconfig, I see the database web5db6 listed 4 times.

    Is there anything else I need to delete? Or how can I correct my stupid mistake?

    By the way, how can you delete a user databases in ispconfig?

    Edit: Problem seems to be solved. See my last post in this thread.
    Last edited: Jun 25, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Now you see the reason why we always post that you shall never edit anything in the database directly!

    Do you have a backup of the ispconfig database? If yes, restore it.

    Click on the delete button and then after a few minutes, empty the recycle bin.
  3. Dennis

    Dennis New Member

    I did not mean to delete something in ispconfig. I did not even want to delete that database. I only wanted to delete the tables of that database and hit the wrong button. Very stupid mistake! Just after this big mistake I started to edit the ispconfig database intentionally.

    Unfortunetely I do not have a backup of the ispconfig database. Is there any other chance to correct my system?

    I am glad that this is not a productive server. But since I have already set everything up and spent some time on that, I would like to avoid starting over again.
    Last edited: Jun 23, 2008
  4. falko

    falko Super Moderator Howtoforge Staff

    Unfortunately not. :(
  5. Dennis

    Dennis New Member

    I think I have solved it by deleting the database through ispconfig. When recreating the database, the options tab shows only one database with that name.

    I hope I do not experience any problems later. So far everything seems to work correctly. Creating databases and deleting them through ispconfig works without any problems.

    Thank you to both of you anyway. Your support is fantastic!
    Last edited: Jun 25, 2008

Share This Page