Add Webmin to the system

Discussion in 'Installation/Configuration' started by sushestvo, Dec 20, 2006.

  1. sushestvo

    sushestvo Member

    I have ISPConfig installed on my fedora core 4 box. Haven't changed anything in a long time, everything works just fine. Except I get insane amount of SPAM. SpamAssassin lets it all through, gives most very little score, some even 0 - like those stock emails. I do have blacklists setup to help - i think 4-5 of them (like spamhaus), but i get about 100 emails a day of spam... ennoying))))
    So since spamassassin cannot do it very well on its own - I want to help by setting up header/body checks. I know I can do it from SSH, but it's easier to have web interface to do such things.
    So my question - is it ok to install Webmin on top of everything to manage SpamAssassin?
  2. bluethunder82

    bluethunder82 Member

    What setting do you have set for spamassassin?

    Also, have you updated spamassassin's checks using sa-update?

    Currently I'm rejecting ~2500 messages using a few custom RBLs, and about ~1500 messages using spamassassin. I'd say something could be wrong with your setup.

    From when I used webmin you need to have spamassassin installed in the default location, whereas ISPConfig has it installed within the /home/ directory.
  3. sushestvo

    sushestvo Member

    What settings are talking about?
    I don't do any updates since I thought ISPConfig suppose to update SA by itself. Am I wrong? :)
    WHere can I look at some statistics of how many|what gets rejected.

    As far as I remember right, u can change the path for SA within Webmin.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Webmin and ISPConfig does not work well togehter, as webmin does not recognice the ISPConfig configuration well and you might destroy your setup when using webmin.

    I recommend to install razor, pyzor ind dcc in a first step and enable it in the spamassassin configuration under /home/admispconfig/ispconfig/tools/spamassassin/

    sa-update is not run by ISPconfig, but you will find it in the above path too.
  5. sushestvo

    sushestvo Member

    Are there any other packages besides webmin that can manage spam assassin? Without interfearing with ISPConfig?

    Also what is razor, pyzor anyway? :eek:

    ANd how do I make SA update itself?
  6. edge

    edge Active Member Moderator

    Actualy it's in:
    Running sa-update gives me an bash: sa-update: command not found error

    When I run: ./sa-update in
    I get this error:
    Can't locate Archive/ in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.4 /etc/perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl) at ./sa-update line 94.
    BEGIN failed--compilation aborted at ./sa-update line 94.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Archive/ is a perl module. Please install this perl module from your linux distribution and try to run the command again.
  8. edge

    edge Active Member Moderator


    This server is setup with the "The Perfect Setup - Debian Sarge (3.1)" howto.
    Did I miss somethig with the setup, or is this "install this perl module" an extra thing that I need to do?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use the sa-update script, so it might be that this perl dependency is not covered by the howto.

    Please run:

    apt-get install libarchive-tar-perl
  10. edge

    edge Active Member Moderator

    Okay, the
    apt-get install libarchive-tar-perl
    did fix the problem.

    After running "./sa-update", it created a new directory;
    In this directory I see all the new downloaded "rules"

    Is this all I need to do, or do I need to set something in a config file to use the new rules?
  11. falko

    falko Super Moderator ISPConfig Developer

    I think this is sufficient, although I haven't tested it yet.
  12. sushestvo

    sushestvo Member

    what if i get this:
    # apt-get install libarchive-tar-perl 
    Reading Package Lists... Done
    Building Dependency Tree... Done
    E: Couldn't find package libarchive-tar-perl
    How can I take care of this problem on my machine? (I run FC4)
  13. edge

    edge Active Member Moderator

    Maybe it's called different for FC4?
    Try "apt-cache search libarchive-tar", or "apt-cache search libarchive" and you should see all the available "libarchive" packages.
  14. sushestvo

    sushestvo Member

    Didn't give me any results :(
    Any other ideas?
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The you may can use the perl console to install it:

    Installation using the Perl Shell

    Login to your command line as root and run the following command to start the Perl shell:

    perl -MCPAN -e shell

    If you run the Perl shell for the first time you will be asked some questions. In most cases the default answers are ok.

    Please note: If you run a firewall on your system you might have to turn it off while working on the Perl shell in order for the Perl shell to be able to fetch the needed modules without a big delay. You can switch it on afterwards.

    The big advantage of the Perl shell compared to the two other methods described here is that it cares about dependencies when installing new modules. I.e., if it turns out that a prerequisite Perl module is missing when you install another module the Perl shell asks you if it should install the prerequisite module for you. You should answer that question with "Yes".

    Run the following commands to install the modules needed by SpamAssassin:

    install ARCHIVE::TAR

    q (to leave the Perl shell)
  16. bwrob

    bwrob New Member

    How do you enable pyzer in sa-update file, where.
    Add a line or something.

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    pyzor is not upadted by sa-update, so you dont have to add it there. Just install the pyzor package from your linux distribution.
  18. dayjahone

    dayjahone Member

    I am trying to update spamAssassin, but am apparently missing perl modules. Everything I could find on this forum says to do this:

    Unfortunately, it can't find the package. so, next try this:

    This is what I got:

    So, I tried it:

    Does anyone have any other ideas? I'm running SuSe 9.2. I'm doing this remotely, so I'm not sure how to find it with yast.
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    The packages for SuSE 9.2 might be outdated, so that the latest spamassassin versions will not work correctly. Please install the latest perl modules as described in the installation manual:
  20. dayjahone

    dayjahone Member

    I did the following again:
    then tried install ARCHIVE::TAR and got the following:
    install Archive::TAR worked, but when I tried to update spamAssassin after that, I get the following:

Share This Page