Adding DKIM to maildomain times out

Discussion in 'General' started by Azraelo, Jun 21, 2023.

  1. Azraelo

    Azraelo New Member

    I have got 5 mail domains configured on my ISPConfig installation.
    The configuration of 3 of those domains worked just fine, but on two of them, it just doesn't work and the ajax request runs into a 500 server error.
    The scenario:
    I am editing the mail domain, activate DKIM, click onto "generate DKIM key" and click onto "save".
    The POST request to https://mydomain:8080/mail/mail_domain_edit.php returns a 500 error after some time.
    On the server side I can see the following error messages in /var/log/apache2/error.log
    On the ISPConfig server side, there is no action regarding the email configuration, even after switching to "debug" log level.

    I wasn't able to change this behaviour for those two domains, no matter what I did. (I can't delete the domains alltogether because there are active IMAP accounts running on them).
    Changing anything on the other mail domains (including the DKIM keys) works just fine.

    Hope you can give me a hint how i could approach this problem.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe a database table is crashed in mysql. Try running an optimize and repair on all tables in dbispconfig database e.g. with phpmyadmin.
    ahrasis and Th0m like this.
  3. Azraelo

    Azraelo New Member

    Thanks for this suggestion.
    I ran repair and optimize on all tables.
    Unfortunately this didn't improve the situation at all.
    Any more ideas?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you read all logs that have timestamp at about the time the problem appears?
  5. Azraelo

    Azraelo New Member

    Yes, I had read all the logs.
    The problem was the line
    $soaDomain = preg_replace("/^\w+\./","",$soaDomain);
    I wasn't running the newest version of ISPConfig and thus here was still the bug with domains, which include a "-". Because of this, the while loop was running endlessly.
    After fixing this entry, now it works just fine.
    Th0m likes this.

Share This Page