adding new site

Discussion in 'General' started by sfrank, May 17, 2006.

  1. sfrank

    sfrank New Member


    i'm not sure if it's a bug or feature so please advise. i've been using ISPConfig for 2 days so i'm not one of the founding members so to speak. :)

    well the first weird issue i encountered is that if i create a new site with 'Create DNS' option checked, it creates a 'www.domain.tld' and 'domain.tld' entry in the postfix local-host-names file, as well as a co-domain without the www (hostname) part, which is the normal behavior. that's fine.

    however even if the 'Create DNS-MX' option is off it creates a "false" MX record for the www.domain.tld in the zone file. i say false, because the user does not want message to be addressed to his/her @www.domain.tld address, but the the @domain.tld only. by default at this point there is no MX record for the domain.tld, only for www.domain.tld - which actually was not requested.

    secondly if i go to edit my co-domain domain.tld and check on the 'Create DNS MX' option it puts an MX entry in the same zone file in which MX record for www.domain.tld is declared in an order in which it cannot be resolved.

    if MX records are in the following order in my zone file (the way ISPConfig puts them):

    www MX 10 admin.domain.tld
    MX 10 admin.domain.tld

    here is what i get:

    hathor:/# host -t mx localhost has no MX record at localhost (Authoritative answer)
    hathor:/# host -t mx localhost MX 10 admin.domain.tld

    if i change the order of these two entries, everything is fine. isn't that weird? does it work fine for other people?
  2. sfrank

    sfrank New Member

    furthermore if i add a site leaving the 'Hostname' field empty everything seems to be fine except one thing.

    - DNS zone file is ok
    - Apache vhost looks alright (both www.domain.tld and domain.tld is there)

    however Postfix local-host-names does not contain domain.tld but www.domain.tld only. why? when i created a site without specifying a www hostname?

    thanks for any hints and ideas.

  3. falko

    falko Super Moderator Howtoforge Staff

    You must go to the DNS-Manager and remove unwanted DNS records there.
    If you had checked the Default DNS and Default MX checkboxes and then unchecked them later on, this will not remove the DNS records, and it's intended that way because otherwise this might have some unwanted impacts. Only the admin and resellers should be allowed to change the DNS records in the DNS Manager.

    Did you select "External Mailserver" for domain.tld?
  4. sfrank

    sfrank New Member

    I can understand why a 'normal' user (not reseller, nor admin) cannot delete an already added MX record. That would make just confusions you're right. But my original question was that why domain.tld is not added to a domain as the default MX record instead of www.domain.tld even if the hostname www is defined on the site creation page? I don't think anyone would like to have a @www.domain.tld email address.

    I'm 99.95% sure that I did not. "Local Mailserver" is the default option though and I did not change it. I can double-check tomorrow, when I'm back to work.

    Could you plz check if you add a site with no hostname specified what do you have in local-host-names concerning that particular domain (2.2.2)?

    Thanks in advance.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe not www, but i know some companies that have email addresses with a country inside. e.g. Thats why we add MX records with hostanme and without hostname.

    ISPConfig creates a co-domain with empty host automatically. I just checked it again on ISPConfig 2.2.2
  6. sfrank

    sfrank New Member

    OK, good call. But what I don't understand is, when you create a new site with www.domain.tld a co-domain gets created whose MX record cannot be resolved thru the nameserver, because the order of the MX records in the zone file is wrong. So on my system without further tweaking there's no way to receive email to @domain.tld addresses, because the sender does not know who is the authorized mailserver of domain.tld. Is it working fine for you?

    If you create a new site let's say, can you tell me what host -t mx localhost shows you please?

  7. falko

    falko Super Moderator Howtoforge Staff

    It's working fine for me, and I'm using ISPConfig to manage the DNS records of all my customers' domains.

    dig @localhost mx
    show the correct result?
    The order of the records in the zone files doesn't matter.
  8. sfrank

    sfrank New Member

    That is insane. It's working fine with dig. I'll keep looking what might cause this anomaly. Anyways, sorry for the false alarm guys. :-\

Share This Page