Address Bar shows IP address instead of URL

Discussion in 'HOWTO-Related Questions' started by SJamG, Nov 24, 2007.

  1. SJamG

    SJamG New Member

    Hi There,

    I am having a problem with my Ubuntu/Apache2 config.

    It loads the page, but displays the IP address instead of URL. I haev edited my virtual hosts file, but it has had no effect.

    Anyone offer any suggestions?

    Thanks for the help


    Here is my Virtual Hosts file :

    [email protected]:/# cd etc
    [email protected]:/etc# cd apache2
    [email protected]:/etc/apache2# cd sites-available
    [email protected]:/etc/apache2/sites-available# ls
    default mailman.conf
    [email protected]:/etc/apache2/sites-available# vi default
    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin [email protected]
    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
    # in /apache2-default/, but still have / go to the right place
    #RedirectMatch ^/$ /apache2-default/

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    Last edited: Dec 17, 2007
  2. Leszek

    Leszek Member

    To see the URL instead of IP address You don't have to change Your server's configuration.
    It looks like You've typed Your IP while installing Joomla.
    You should type the url of the site.
    You can correct this error by replacing the ip by url in configuration.php and some parts of the database.You have to look for Yourself because records in which You can find the ip depend on the components You installed.
    Last edited: Nov 24, 2007
  3. SJamG

    SJamG New Member


    Its working perfectly now!! Thank you very much!


Share This Page