again on webalizer stats

Discussion in 'Installation/Configuration' started by gilas, Oct 3, 2006.

  1. gilas

    gilas Member

    Dear Falko and folks,
    this is a very annoying problem. Some months ago I installed successfully ispconfig and webalizer. Then I reinstalled ispconfig 2.2.6 and since installation webalizer seems not work propely.

    I tried all you suggest: edit crontab etc., waited for 24 hours and then ran the php program to force the system to a manual creation of the records:

    php /root/ispconfig/scripts/shell/webalizer.php

    (CLI mode), nothing appears.

    Then I tried to restart ispconfig, none -- and check log errors (/var/log/messages), give a wich webalizer command.

    All seems to be really OK, I can login and view the stats, but the stats are not update..... could you help me??

    Thank you....
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not correct, you use the wrong PHP binary! The correct command is:

    /root/ispconfig/php -q /root/ispconfig/scripts/shell/webalizer.php

    But you will have to run the logsplit script (logs.php) before you run the webslizer script.
  3. gilas

    gilas Member


    I ran:
    /root/ispconfig/php/php -q /root/ispconfig/scripts/shell/logs.php

    /root/ispconfig/php/php -q /root/ispconfig/scripts/shell/webalizer.php

    but nothing seems appear.... no logs on video... just less than half second the linux prompt returns, but no messages or other...

    what can I do more?
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    df -h
  5. Jack98

    Jack98 New Member

    Same problem

    I have the same problem here. Same origin, same results. Have performed same tests with same results.

    The result of my df -h is:

    179G 5.0G 165G 3% /
    /dev/sda1 99M 14M 80M 15% /boot
    /dev/shm 474M 0 474M 0% /dev/shm

    Thanks, Jack
  6. Jack98

    Jack98 New Member

    Fixed it

    Hello all again,

    I have fixed it. The problem seemed to be that in my last update, ispconfig have updated the script (webalizer.php in this case) and not the ispconfig tables in the DB. So webalizer.php was checking in the table for a new field in the table isp_isp_web called webalizer_stats to have value 1, but that field was not in my table. So just added it, filled it with 1's and it worked!

    Then I have manually created temporary symbolic links of /homw/www/ to the months I lost... and run webalizer again...

    logs.php restored the links after that (I previously have deleted them all)

    Any question? just post...

  7. gilas

    gilas Member


    Just solved like Jack98 suggest.... unfortunately some days ago I added a table named: 'webalizer_stat' and not ' webalized_stats' so that ISPConfig was not running as expected.
    Now I've updated the tables manually and all seems to work....

    thank you again!

Share This Page