All domains in the system shows apache's default page.

Discussion in 'Installation/Configuration' started by sza, Mar 9, 2016.

  1. sza

    sza Member

    A little background...

    I've done an distribution upgrade (from ubuntu 12.04 - to 14.04).

    After the upgrade ISPConfig didn't work well. So I've passed through all the installation steps from the beginning.
    (In order to make sure that there is no any missing package etc..)
    after reinstalling all worked well, but I didn't have the website's list and settings. The system was clean.
    So I went to the /var/backup direcory and found a backup with a sql file of the dbispconfig database.
    I restored it on the empty db and now I can see all the websites in the system, but when I type an address of one of them I get ubuntu+apache's default page. (equivalent to "it works" page.)
    I thought that the reason might be that the directory "sites-available" inside /etc/apache2 is not included in apache2.conf.
    When I include it inside that file, apache won't start- giving this error:
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8081
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8080

    Any ideas? =\

    Thank you very much and sorry for the long question.

    Tzahi Serruyam
  2. sza

    sza Member

    Update: when I include 'sites-available' directory and exclude 'sites-enabled' from apache's conf,
    It starts normally, and entering any of the websites shows ISPConfig's "forbidden" page.
    Connecting to an ftp accounts works great.
    When I upload a file it is being upload with the same permissions/ownership it should be. (e.g client5:web6).

    What am I missing? :(

  3. Well-Known Member HowtoForge Supporter

    first of all, you may need to run update.php from the ispconfig.tar.gz the next time you do system upgrade.
    Sometimes there are some changes like from apache 2.2 to 2.4 which sometimes needs to be adjusted.
    Just a side note, if you installed jailkit, there is a new version > 2.19 - however this is not the solution to your current issue.

    If you recover from a backup it's not sufficient to only restore the database, you need to restore the /etc/group and /etc/passwd files before you recover website folders.
    If you just reinstalled ISPConfig without complete reinstallation of the system you need to go to Tools page in ISPConfig and do a rsync of everything - this may take a while to complete.

    The proper solution is to include sites-enabled only not the sites-enabled, please revert that change.
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8081
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8080
    Please make sure you don't include files twice.

    Make sure you have
    # Include the virtual host configurations:
    IncludeOptional sites-enabled/
    once! in your apache2.conf

    Check your vhost files if they have any
    Deny from all / allow from all
    ( or similar ) entries and adjust it to the new syntax
    Require all denied
    sza likes this.
  4. sza

    sza Member

    Thank you for your reply,
    I've restored sites-enabled and removed sites-available from apache configurations, and changed the files according to the instructions you've mentioned (with the new apache rules.)
    Yet the same error appears.
    In the log file it looks like that:
    [Wed Mar 09 09:15:44.948194 2016] [authz_core:error] [pid 14791] [client] AH01630: client denied by server configuration: /var/www/clients/client5/web6/cgi-bin/php5-fcgi-*

    Please help :(
  5. Well-Known Member HowtoForge Supporter

    means that there is an error in the vhost configuration or given .htaccess file in that folder with old syntax for Deny/Allow from all or similar.

    And I really hope you recovered sites-available since sites-enabled ideally should only be symlinks to the other folder, but if it works you probably did it right - just don't touch it yet but check the vhost file and web folders .htaccess files for old syntax.
    sza likes this.
  6. sza

    sza Member

    Thanks alot ,
    I've figured out the symbolic links issue and after creating them and editing the entire files it still didn't work.
    Than I ran the update.php file from the installation directory and all seems to work fine now.
    I guess it fixes the apache's configuration somehow.

    Thank you very much!
  7. Well-Known Member HowtoForge Supporter

    Indeed it does - I should have thought about that when writing the first line of my first reply :) Sorry for that :(
    Glad it works now :)
    sza likes this.

Share This Page