amavisd dead but subsys locked

Discussion in 'Installation/Configuration' started by asyadiqin, Jan 15, 2007.

  1. asyadiqin

    asyadiqin New Member

    I've followed the installation guide from "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)" and everything was going well.

    However, when I came to the part where I have to restart Amavis, there was an error message

    I check the status and got this response

    This is what I get from the logs on /var/log/maillog

    Somehow, something is stopping amavisd from running and I have no idea what it is. Any ideas?
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to reboot the system?
  3. asyadiqin

    asyadiqin New Member

    Not when I received those error. I did try to reboot it but accidentally shutdown the server instead. I will have to go to the datacentre and physically reboot the server next week.

    beside rebooting the server, could there be any other possible reason for amavisd not starting properly.

    FYI, prior to following the guide, this is a freshly installed server, which I followed from "The Perfect Setup Guide for Fedora Core 5". I do not know if there could be any connection to that.

    Anyway, I'll update you when I've rebooted the server. Thanks.
  4. falko

    falko Super Moderator ISPConfig Developer

    I thought rebooting the server was easier than telling you to check pid and lock files (e.g. in /var/run/amavisd/). Those files (that could cause the error) are removed on reboot.
  5. asyadiqin

    asyadiqin New Member

    Rebooting Didn't Solve The Problem

    Just an update. Seems the reboot didn't actual do anything. The boot-up log specified that amavisd started up ok, but when I entered the following in shell

    it still return the same error

    I can find the .pid file but not the .lock file. Deleted the .pid file and tried restarting amavisd, but same thing.

    Anyway, since I am at the datacentre, I decided to try to do a fresh install on the server and try again. Hopefully, this time it will installed without any problem.

    One last question, though I know its out of topic. Assuming that I get this to work, eg. "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)", is there anyway to make it work with IspConfig?

    Would appreciate any tips, guides or hints from anyone who managed to get this setup working with IspConfig.

    Thanks again.
  6. falko

    falko Super Moderator ISPConfig Developer

    No, this setup is completely incompatible with ISPConfig.

Share This Page