amavisd-new: virus-check ok, but no spamassasin?

Discussion in 'Installation/Configuration' started by muelli75, Mar 4, 2017.

  1. muelli75

    muelli75 Member


    I try to set up a multidomain-enviroment on debian jessie. Some basicparts are done, some are to to. Like configuring the mailserver.
    postfix:amd64/jessie 2.11.3-1 uptodate
    postfix-doc:all/jessie 2.11.3-1 uptodate
    postfix-mysql:amd64/jessie 2.11.3-1 uptodate
    amavisd-new:all/jessie 1:2.10.1-2~deb8u1 uptodate
    spamassassin:all/jessie 3.4.0-6 uptodate
    is up and running and delivers mails to

    dovecot-core:amd64/jessie 1:2.2.13-12~deb8u1 uptodate
    dovecot-imapd:amd64/jessie 1:2.2.13-12~deb8u1 uptodate
    dovecot-lmtpd:amd64/jessie 1:2.2.13-12~deb8u1 uptodate
    dovecot-mysql:amd64/jessie 1:2.2.13-12~deb8u1 uptodate
    dovecot-pop3d:amd64/jessie 1:2.2.13-12~deb8u1 uptodate
    dovecot-sieve:amd64/jessie 1:2.2.13-12~deb8u1 uptodate

    I did as described
    and disabled spamassasin-services
    service spamassassin stop
    systemctl disable spamassassin​

    If I check recieved mails, I can see lines for viruses-check

    X-Virus-Scanned: Debian amavisd-new at
    but I dont see lines like

    X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
    X-Spam-Status: No, score=-102.9 required=7.0 tests=BAYES_00,RCVD_IN_MSPIKE_H5,
    autolearn=ham autolearn_force=no version=3.4.0
    I tried do force judging mails as spam by sending mails from a different mailserver and adding some known spam-words and links. But it wasnt successful, no mail shows X-Spam-Header-Lines.

    Is there still a spam-check? If not - please give some hints what to do to enable spam-check. Thank you in advance!

  2. muelli75

    muelli75 Member

    Hi out there!

    Did a test by sending a mail from another mailserver as described in

    The Mail was discarded/marked - so it works. Obviously my previous testmails didnt triggerd spamassasin to spend some spam-score.

    Best regards, Martin
  3. florian030

    florian030 Well-Known Member HowtoForge Supporter

    set the tag-level for the mail-policy to if you really need this data in the header
    muelli75 likes this.

Share This Page