Another: open /var/www/ failed Permission denied

Discussion in 'General' started by Arien, Apr 19, 2014.

  1. Arien

    Arien New Member

    I'm sorry if I bother you all with this, but I have searched and didn't find any solution for my case.

    First of all, I followed this to install ISPConfig on Wheezy:

    ISPConfig Version:

    All runing fine, except for the huge error messages I'm having from all my hosted sites:

    [crit] 27162#0: *26545 open() "/var/www/" failed (13: Permission denied), client:, server:, request
    : "GET /?p=1017 HTTP/1.1", host: ""
    Sites are runing fine, no errors showing by any client, but they're generating too many Permission failed in each error.log, slowing down the entire server.
    Take in mind that every get for every web generates about 5 error entries in the log.

    Those are file permissions for each web hosted:

    drwxr-xr-x 9 root root    4096 mar  2 00:30 .
    drwxr-xr-x 9 root root    4096 abr 11 11:54 ..
    drwxr-xr-x 2 web2 client1 4096 mar  2 00:30 backup
    drwxr-xr-x 2 web2 client1 4096 feb 28 11:44 cgi-bin
    drwxr-xr-x 2 root root    4096 abr 19 00:30 log
    drwx--x--- 2 web2 client1 4096 feb 28 11:44 private
    drwxr-xr-x 2 root root    4096 feb 28 11:44 ssl
    drwxrwxrwx 2 web2 client1 4096 abr  8 08:32 tmp
    drwx--x--- 7 web2 client1 4096 abr 19 21:37 web
    I tried chmod 755 /web and then errors stopped, but I know those are not right permissions.

    I saw someone else looking for this time ago, and Falko told it's safe to ignore those errors, and it's ok from security point of view but not from performance point of view.

    Nginx is running with www-data:www-data

    www-data 22184 22183  0 abr18 ?        00:00:05 nginx: worker process
    www-data has this id:

    uid=33(www-data) gid=33(www-data) grupos=33(www-data),5003(ispapps),5004(ispconfig),5005(client1)
    web2 has this id:
    uid=5005(web2) gid=5005(client1) grupos=5005(client1),5002(sshusers)
    Does anybody know if there's any fix or workaround?
    Thanks for your time.
    Last edited: Apr 19, 2014
  2. srijan

    srijan New Member HowtoForge Supporter


    I guess this thread might be useful for you.

  3. Arien

    Arien New Member

    Thank you srijan, but as far as i know suPHP works for Apache.
    I'm runing Nginx + phpFPM, and it's working fine except those damn error messages.
  4. Arien

    Arien New Member

    Ok, tried updating to ISPConfig, and nothing changed.

    Does anybody know where can I find an option to continue debug?

    Thanks again.
  5. srijan

    srijan New Member HowtoForge Supporter

Share This Page