anyone using wordpress or even wordpressmu ?

Discussion in 'Technical' started by Ovidiu, Nov 24, 2005.

  1. Ovidiu

    Ovidiu Active Member

    I have severall big question to which ido not find any answer on their forums:

    first of all, I am trying to setup wordpressmu, which will create blogs as subdomains, so they say I need a wildcard domain,

    one user states this:

    How would I achieve this in my ispcfg panel? I tried setting a * to myIP DNS record, but that does not help so far...

    another requirement is: Apache FollowSymlinks must be switched on. This will disappear in later releases....

    any hints for me? also Apache mod_rewrite is needed

    another user states:
    and here I am, admin and all, not able to setup one myself :eek:

    any hint is welcome...
  2. falko

    falko Super Moderator Howtoforge Staff

    You can use the Apache Directives field in ISPConfig for it.
    That depends on your Apache configuration, not on ISPConfig. In most distributions mod_rewrite is already enabled.
  3. Ovidiu

    Ovidiu Active Member

    I already tried that, what will happen to the lines I add there? where will ispcfg insert them? just curious what happens behind the curtains...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig adds the lines in the vHost section of the apache configuration of this site. But first ISPConfig tests if they are valid, if not the will be commented out.
  5. Ovidiu

    Ovidiu Active Member

    what if I want to add 2 directives? one per line or how do I add them in here?

    talking about this:

    leads to this:
    so where is the error? why are both not supported all of a sudden? if I only use Options FollowSymLinks it gives me no error and seems to work...
  6. Ovidiu

    Ovidiu Active Member

    as I did not get it working I have been playing around. what I isnerted into apache directives is this:
    and the output generated in the Vhostsfile is this:

    is this valid? can there be a directory inside a vhost ? is that ok? I was not sure how to do it otherwise...
  7. falko

    falko Super Moderator Howtoforge Staff

    Yes, this is valid.
  8. Ovidiu

    Ovidiu Active Member


    It seems I partially solved my problem: I opened webmin, went to module options of bind (although I never used this) and changed allow wildcards from NO to YES.

    now I can ping a blog which I had created for testpurposes... still DNS does not resolve it but I guess I am on the right way :)
  9. falko

    falko Super Moderator Howtoforge Staff

    It's working for me:
    mh1:~# dig
    ; <<>> DiG 9.2.1 <<>>
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10278
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    ;                        IN      A
    ;; ANSWER SECTION:         86400   IN      A
    ;; Query time: 40 msec
    ;; SERVER:
    ;; WHEN: Sat Aug 26 14:20:53 2006
    ;; MSG SIZE  rcvd: 48
  10. jonwatson

    jonwatson New Member

    Can the orignal poster (or someone else) elaborate on how to enable wildcard DNS within ISPConfig?

    I need it for WordpressMU as well.

  11. Ovidiu

    Ovidiu Active Member

    like I said I used webmin => servers => bind => allow wildcard DNS (/I don't know how to do this otherwise)

    Then you need to setup a wildcard subdomain (dunno if this is the right term for it) but again I am unsure which of these two methods is right, I just know I did both and its working:

    a) in ispcfg enter a new dns record like this: * as hostname and your IP in the IP field
    b) in ispcfg enter a new dns record like this: * as hostname and your IP in the IP field

    I dunno wich one is correct but having both added does no harm and works.
  12. jonwatson

    jonwatson New Member

    Thanks. I saw the post, but I was hoping for a way to part 1 within ISPConfig. However, I've mucked around a bit with your instructions and I think I have it working. I need a little more time to be sure that my DNS has propagated properly to be sure, but it looks good.

Share This Page