Apache can't verify SSL certificates

Discussion in 'Server Operation' started by Ludwig, Oct 1, 2019.

  1. Ludwig

    Ludwig New Member


    I have an Ubuntu (16.04) Server with Apache on it. A Few month ago i created a Certificate for the https connection (with letsencrypt) and everything worked fine. For about a week now the Apache server can not verify certificates anymore (i am trying to send a EMail). HTTPs still works.

    Apache ErrorLog:
    "... stream_socket_client(): SSL operation failed with code 1. ... certificate verify failed..."

    It started after i created a new certificate for an EMail server (with letsencrypt, running on the same server). But that can be a coincidence.
    By the way, i can verify certificates with the openssl command without problems.

    I googled about the problem the last 5 days, 3-4 hours a day, but was not able to fix it. Nothing works.

    Can someone help me?

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Does that host now have two certificates? My guess is they are now mixed somehow.
    You can set up all services on that host to use the same certificate, that has worked on my setup.

Share This Page