Apache Directive error produced

Discussion in 'Installation/Configuration' started by rfnx, Dec 14, 2023.

  1. rfnx

    rfnx New Member

    please help!

    Installed mediaiki on https://wiki.site.xyz and it started with the Apache default page instead of the Mediawiki index.php.
    Tried to fix that by adding

    RewriteRule ^/index.php [L]*

    to the Apache Directive of the site.
    wich I found here browsing for a fix ...


    Now all sites including ISPC start with a connection refused error page:
    upload_2023-12-14_5-9-33.png

    Tried to find the DOCUMENTROOT entry in the vhost for the wiki site but cant find nothing :(

    Have fun laughing but please tell me how to reverse that :eek:

    Here the output of the test script:


    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Debian GNU/Linux 12 (bookworm)
     
    [INFO] uptime:  05:41:00 up  2:10,  5 users,  load average: 0,00, 0,00, 0,00
     
    [INFO] memory:
                  gesamt       benutzt     frei      gemns.  Puffer/Cache verfügbar
    Speicher:       15Gi       2,3Gi        12Gi       4,5Mi       1,5Gi        13Gi
    Swap:             0B          0B          0B
     
    [INFO] systemd failed services status:
      UNIT            LOAD   ACTIVE SUB    DESCRIPTION
    ● apache2.service loaded failed failed The Apache HTTP Server
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    1 loaded units listed.
    
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.11p1
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 8.2.7
    [INFO] php-cgi (used for cgi php in default vhost!) is version 8.2.7
    
    ##### PORT CHECK #####
    
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 80 (Webserver) seems NOT to be listening
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening
    
    ##### MAIL SERVER CHECK #####
    
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.
    
    ##### RUNNING SERVER PROCESSES #####
    
    [WARN] I could not determine which web server is running.
    [INFO] I found the following mail server(s):
        Postfix (PID 1244)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 657)
    [INFO] I found the following imap server(s):
        Dovecot (PID 657)
    [INFO] I found the following ftp server(s):
        PureFTP (PID 1300)
    
    ##### LISTENING PORTS #####
    Server)        ()
    Local        (Address)
    [anywhere]:3306        (797/mariadbd)
    [localhost]:10023        (487/postgrey)
    [localhost]:53        (662/named)
    [localhost]:53        (662/named)
    [localhost]:53        (662/named)
    [localhost]:53        (662/named)
    [localhost]:953        (662/named)
    [localhost]:953        (662/named)
    [localhost]:953        (662/named)
    [localhost]:953        (662/named)
    [localhost]:11332        (727/rspamd:)
    [localhost]:11333        (727/rspamd:)
    [localhost]:11334        (727/rspamd:)
    [anywhere]:143        (657/dovecot)
    [anywhere]:110        (657/dovecot)
    [anywhere]:25        (1244/master)
    [anywhere]:21        (1300/pure-ftpd)
    [anywhere]:22        (674/sshd:)
    [anywhere]:465        (1244/master)
    [anywhere]:587        (1244/master)
    [anywhere]:993        (657/dovecot)
    [anywhere]:995        (657/dovecot)
    [localhost]:11211        (661/memcached)
    [localhost]:6379        (664/redis-server)
    ***.***.***.***:53        (662/named)
    ***.***.***.***:53        (662/named)
    ***.***.***.***:53        (662/named)
    ***.***.***.***:53        (662/named)
    *:*:*:*::*:3306        (797/mariadbd)
    *:*:*:*::*:10023        (487/postgrey)
    *:*:*:*::*:53        (662/named)
    *:*:*:*::*:53        (662/named)
    *:*:*:*::*:53        (662/named)
    *:*:*:*::*:53        (662/named)
    *:*:*:*::*:953        (662/named)
    *:*:*:*::*:953        (662/named)
    *:*:*:*::*:953        (662/named)
    *:*:*:*::*:953        (662/named)
    *:*:*:*::*:11332        (727/rspamd:)
    *:*:*:*::*:11333        (727/rspamd:)
    *:*:*:*::*:11334        (727/rspamd:)
    [localhost]43        (657/dovecot)
    [localhost]10        (657/dovecot)
    *:*:*:*::*:25        (1244/master)
    *:*:*:*::*:21        (1300/pure-ftpd)
    *:*:*:*::*:22        (674/sshd:)
    *:*:*:*::*:465        (1244/master)
    *:*:*:*::*:587        (1244/master)
    *:*:*:*::*:993        (657/dovecot)
    *:*:*:*::*:995        (657/dovecot)
    *:*:*:*::*5833:beff:fe44:53        (662/named)
    *:*:*:*::*5833:beff:fe44:53        (662/named)
    *:*:*:*::*5833:beff:fe44:53        (662/named)
    *:*:*:*::*5833:beff:fe44:53        (662/named)
    *:*:*:*::*:6379        (664/redis-server)
    2a03:4000:55:f45:583:53        (662/named)
    2a03:4000:55:f45:583:53        (662/named)
    2a03:4000:55:f45:583:53        (662/named)
    2a03:4000:55:f45:583:53        (662/named)
    
    
    
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination  
    f2b-postfix-sasl  6    --  [anywhere]/0            [anywhere]/0            multiport dports 25
    f2b-sshd   6    --  [anywhere]/0            [anywhere]/0            multiport dports 22
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination  
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination  
    
    Chain f2b-postfix-sasl (1 references)
    target     prot opt source               destination  
    REJECT     0    --  ***.***.***.***         [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     0    --  ***.***.***.***        [anywhere]/0            reject-with icmp-port-unreachable
    RETURN     0    --  [anywhere]/0            [anywhere]/0    
    
    Chain f2b-sshd (1 references)
    target     prot opt source               destination  
    RETURN     0    --  [anywhere]/0            [anywhere]/0    
    
    
    
    
    ##### LET'S ENCRYPT #####
    acme.sh is installed in /root/.acme.sh/acme.sh
    
    
     

    Attached Files:

    Last edited: Dec 14, 2023
  2. rfnx

    rfnx New Member

    I could fix it with a ispconfig_update.sh --force ;) sigh

    but can you please tell me how to make ISPC start the Mediawiki index.php ?
     
  3. rfnx

    rfnx New Member

    OK,. solved it myself adding RewriteRule index\.html index.php [NC,R] to Custom php.ini settings :)
    upload_2023-12-14_7-5-40.png
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The test script shows Apache is not running.
    Is that still the case if you run the test script now?
     
  5. pyte

    pyte Well-Known Member HowtoForge Supporter

    How about just deleting the .html as you don't need it anyways?

    If you want to keep both it's easiest to set a directive either through ispconfig or .htaccess and prefer the .php over the .html like this:
    Code:
    DirectoryIndex index.php index.html 
     
    till likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    As @pyte suggested, the correct solution would likely be to delete the index.htm file and remove the rewrite rule you added.
     
  7. rfnx

    rfnx New Member

    Works with
    {DOCUMENT_ROOT}/index.php [L]

    Thank you!
     

Share This Page