Apache exit signal Segmentation fault (11) - PHP - Blank page

Discussion in 'Server Operation' started by Salvis, Jun 13, 2007.

  1. Salvis

    Salvis New Member


    I upgraded my system from Fedora 5 to Fedora 6 (x86_64) using this: http://www.ioncannon.net/system-administration/99/upgrade-fc5-to-fc6-with-yum/
    i updated all software via yum update
    Now httpd (x86_64 2.2.4-2.fc6) not showing PHP pages. PHP is installed: php x86_64 5.1.6-3.6.fc6

    Error log shows:
    When i trying to open .php page i see blank page. .html pages showing normal.

    I have no idea how to fix it. Please help me.
  2. falko

    falko Super Moderator ISPConfig Developer

  3. matej

    matej New Member

    Exactly same problem. After I changed what falko proposed I get errors:

    (9)Bad file descriptor: apr_socket_accept: (client socket)

    during reload (when I change something in configuration so apache configuration is reloaded). And after that when I click on some PHP site I get error:

    [notice] child pid XXXXX exit signal Segmentation fault (11), possible coredump in /tmp

    If I manualy restart apache everything works fine (If I just reload, still get same error).

    Any Ideas?
  4. falko

    falko Super Moderator ISPConfig Developer

    Is there a coredump in the /tmp directory?
  5. matej

    matej New Member

    Yes, I think so. There are some core.XXXXX files in /tmp directory.
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in the latest one?
  7. matej

    matej New Member

    Hm. Where should I open this file? If I open in editor it has ureadable format...


    and it's about 82 Mb huge file.


    p.s. Temporary I use (bad) "workaround". I changed script /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php to "restart" apache instead of reload. Becouse this is dirty workaround I would be very greatfull if we can find solution for my problem
  8. TeckniX

    TeckniX New Member

    I know this is an old thread but I figured I'd bring it back to life.

    I'm currently experiencing the same issue and cannot really figure out what's happening.

    I've enabled the CoreDump using this tutorial:


    I can then read the GDB core dump via gdb with the following:
    gdb httpd -c core.8352

    The part where apache fails is at the end of the dump:
    Reading symbols from /usr/lib/php/modules/pdo_sqlite.so...done.
    Loaded symbols for /usr/lib/php/modules/pdo_sqlite.so
    Error while mapping shared library sections:
    %0*Zx, 0x%0*Zx): No such file or directory.
    Core was generated by `/usr/sbin/httpd'.
    Program terminated with signal 11, Segmentation fault.
    [New process 7688]
    #0  0x011aee2b in ?? () from /etc/httpd/modules/libphp5.so
    I've tried to disable a couple of the modules by renaming them, but the same issue keeps happening. Anyone have any idea/tips on how I can identify the culprit and get this working correctly?

    as a side note I'm on PHP 5.1.6 and Apache 2.2.3 using MPM worker.
  9. Norman

    Norman Member HowtoForge Supporter

    This may be caused by a conflict between php dynamically loaded modules and apache included modules.

    Check out the pdo manual, uninstall either the php modules from php repository or debian repository.

  10. darraghp

    darraghp New Member

    Old post but I recently hit this issue after installing php5-sybase on Ubuntu Lucid.

    Turned out my syntax for mssql_connect was incorrect. I was using double quotes and should have been using single.

    so ensure check your documentation and ensure your syntax is correct.
  11. Frappyjohn

    Frappyjohn New Member

    child pid 99999 exit signal Segmentation fault - one (tentative) solution

    I have had this problem also after migrating a production server from Redhat ES 5 to Ubuntu 10.4 and the LAMP stack. It has occurred erratically after making seemingly innocuous edits to production programs.

    So far I have "solved" or at least eliminated each occurrence, but not after a lot of hair pulling. The problem seems to be associated with undefined variables. By consulting my Apache/PHP log for "PHP Notices" (!) of undefined variables and eliminating them, I managed to solve the problem tonight, at least for the time being. Pay attention to undefined variables which are used in function calls (e.g. substr()) and to undefined indirect variables (e.g. ${$MyUndefinedVariable}).

    Still, this is a PHP bug since the segmentation fault is occurring without PHP first throwing an error.
  12. jozza

    jozza New Member

    Your findings seem to have solved this same problems for me too. This only happened on Linux, never on Windows. I'll keep observing it, but so far it looks good. I haven't noticed a blank page since i fixed all undefined variables.
    I've been struggling with this problem for over a year, so i'm grateful to you for sharing this.
  13. bms

    bms New Member

    if anyone else comes across this problem its because you have an infinite loop in your code, usually a function calling another function which in turns calls the original function again :eek:

Share This Page