Apache fails to start after disabling LetsEncrypt check

Discussion in 'General' started by belkins, Aug 19, 2020.

  1. belkins

    belkins New Member

    Hello! I've disabled LetsEncrypt check in ISPconfig settings and right after applying this settings my WebUI failed to reload.
    Apache does not start anymore.
    It fails to start with the following error:

    AH00111: Config variable ${APACHE_RUN_DIR} is not defined
    apache2: Syntax error on line 80 of /etc/apache2/apache2.conf: DefaultRuntimeDir must be a valid directory, absolute or relative to ServerRoot

    I've tried to update ispconfig by running the script, which includes reconfiguring the services, with no success.

    Would somebody, please point me, on how to fix it?

    Found the same issue:

    Tried to remove symlinks from /etc/apache2/sites-enabled/
    After removing 000-ispconfig.conf apache has started.

    Still can not understand how to fix that .conf manually to make ispconfig run as usual.
    Last edited: Aug 19, 2020
  2. belkins

    belkins New Member

    Finally there was a problem with ports.
    Long time ago i changed phpmyadmin port (phpmyadmin.conf) to 8081.
    And Apps port (000-apps.vhost) which initially(by defalut) was 8081 to 8088.

    When i applied settings to Skip lets encrypt check Apps, port (8088) changed to default value (8081) and caused collision with phpmyadmin port (8081). This error caused apache2 fail to start.
    Th0m likes this.
  3. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Any reason why you did not join pma and other app in one port 8081? It seems easier to me.

Share This Page