Apache - mod_fcgid issue

Discussion in 'General' started by robertlouwen, Mar 12, 2010.

  1. robertlouwen

    robertlouwen New Member

    Hello all,

    On my newly installed server I have created two sites with php-fast/cgi
    When I restart apache i get these errors:
    Socketpath cannot occur within < Virtualhost > section
    MaxProcessCount cannot occur within < Virtualhost > section

    Apache failed to start !

    Now back in ISPConfig I change the sites to php-Suphp and restart Apache and everything is fine.

    I attached the "naughty" ../sites-enabled/something.org.vhost

    PS I followed this tutorial "Perfect server Fedora 12 with ISPConfig 3.0.2" with a i686 box.
    I build it with copy and paste

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    May you please remove this large dotted line from your addy, it breaks the layout. Thanks.
  3. robertlouwen

    robertlouwen New Member

    offcourse !
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If the mod_fcgi settings do not work on your system, its most likely to an incompatibility in mod_fcgid versions as they work e.g. on Debian. I will have to take a look why Fedora 12 does not support this. You can remove the lines in the file /usr/local/ispconfig/server/conf/vhost.conf.master
  5. robertlouwen

    robertlouwen New Member

    Again good evening Till,

    I understand how much work it is to make all these tutorials and I can imagine that you don't have the time to test every possible server config.
    That's why I posted this issue, not to nag you, I can live with php-Suphp, but to "help" you make a perfect server.
    Last edited: Mar 28, 2010
  6. rudisoft

    rudisoft New Member


    Hello everyone,

    Just wanted to confirm that i have the exact same problem.

    I am using Fedora 12 x86_64 and apache won't start unless those 2 lines are disabled.
    Other than that mod_fcgid seems to work ok (managed to get phpinfo).

  7. robertlouwen

    robertlouwen New Member


    Problem seems to be solved with ISPConfig v3.0.2.1 !
  8. bajodel

    bajodel New Member

    ..but the large dotted line from your addy ..still there :)

Share This Page