Apache not starting SUEXEC Problem

Discussion in 'Installation/Configuration' started by muekno, Jan 17, 2015.

  1. muekno

    muekno Active Member HowtoForge Supporter

    System OpenSuSe 13.1
    Had a running ISPConfig server, planned serving a server cluster of ISPConfig server, with a second ISPConfig Mailserver installed end of last Year. Today install the web server. Before running the ispconfig install script I would add users in the admin servers MySQL Database useing PHPMyAdmin. Thereby realized Apache not running. In the meantime I did an OS Update and a reboot.
    Apache failure:
    Jan 17 15:44:29 admin start_apache2[15425]: AH00526: Syntax error on line 29 of /etc/apache2/sites-enabled/000-apps.vhost:
    Jan 17 15:44:29 admin start_apache2[15425]: SuexecUserGroup configured, but suEXEC is disabled: Invalid owner or file mode for /usr/sbin/suexec2
    Searching solutions I only found setting correct owner and filerights, all correct. Other ISPConfig Servers same version and update level are working. Compareing running and failing server I find no difference

    Need help, Thank you
  2. muekno

    muekno Active Member HowtoForge Supporter

    comparing to running server I found filerigths not equal
    chmod 4755 /usr/sbin/suexec2 fixed it.
    I'am sure I did this before, as found in articles to this problem,
  3. Sked

    Sked New Member

    I have OpenSuse 13.2 and i get the same error. And this fix my problem too.

Share This Page