Apache2 Default Webpage Instead of Website

Discussion in 'Installation/Configuration' started by BharatG, Mar 16, 2017.

  1. BharatG

    BharatG New Member


    I have an ispconfig 3 server configured which works well when the internet is directly connected to the server.
    Now I've introduced a router in between and forwarded the following ports to the fixed local ip assigned to the server :
    8080, 80, 3306, 22, 8081, 53, 443, 21

    When i try accessing the page via the IP address, I can see Apache2 Default webpage instead of the index page of the client1 website, which is not the same when I have a direct connection.

    I tried searching for the answer on the forum but could find either the Admins questions for "Is your server behind a router?" unanswered or the issue with the router thing is completely different.

    It would be great if I could get this working.

  2. Tuumke

    Tuumke Active Member

    If you are willing to share (you could also send a PM):
    1. What is the domain used?
    2. What is the ip adress of the server?
    3. Did you create: Client > Website > DNS?
  3. BharatG

    BharatG New Member


    I did look through that link and since I'm not using a mailing server I haven't forwarded the SMTP and POP ports.
    Also like I mentioned, the whole website works well without a router in between, But I get the Apache2 default page when I put a router in between and forward the requests to the local ip assigned to the server
  4. florian030

    florian030 Well-Known Member HowtoForge Supporter

    and your vhosts are ALL listen to the same ip / * ?
  5. BharatG

    BharatG New Member

    Yes, The router passes all the ports, mentioned in the original post, to the local IP that is static to the server. I can get the isp config page when I access the page via IP:8080
    And yes I've put the service as All
  6. BharatG

    BharatG New Member

  7. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    I don't quite understand what that means, but I believe @florian030 was questioning if all your vhosts are set to the same ip address, or all set to '*' for the address, not mixing the two. (The output of 'apachectl -S' might help clear this up.)

    Did you regenerate your website config after changing ip addrs?
  8. BharatG

    BharatG New Member

    Sorry for the late reply.

    I've put in the same IP for all the vhosts
    and no I have not regenerated the wesite config after changing the IP address.
    Do you want me to run the apachectl -s on the server behind the router?
  9. ganewbie

    ganewbie Member HowtoForge Supporter

    @BharatG ,
    I think what they meant is the IP for all of your sites should show *.
    Here is how:
    Goto sites --> pick your domain and click on it--> Under the first tab "Domian" the third line is IPv4 address you need to have a * there and not the IP address. Hope that helps.
  10. BharatG

    BharatG New Member


    Thanks for the clarification.
    Even after doing that I still get the same result. Apache page and not the webpage :(
  11. ganewbie

    ganewbie Member HowtoForge Supporter

    Welcome, did you restart apache?
  12. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Can you check your /etc/network/interfaces and /etc/hosts? They should be something similar to the one in this tutorial page.

    And can you also try to do a full resync and try accessing your website(s) again when it is fully completed?

    What the access log(s) for your website(s) and apache recorded if you try to access your website(s)?
  13. BharatG

    BharatG New Member

    Sorry for the late reply again.
    I keep missing the mail from the forums on my gmail.
    Anyway, I did restart apache and the server alltogether as well

Share This Page