Apache2 not starting

Discussion in 'Installation/Configuration' started by Ganther, Feb 6, 2009.

  1. Ganther

    Ganther New Member

    I have been trying to figure out why Apache will not start. I am running Ubuntu 8.10 following the perfect setup guide running ISPconfig.

    Apache was running and the Vhosts_ispconfig.conf was blank when creating a new site tried following some of the possible solutions in the forums now Apache won't start. Here are some of the troubleshooting I found in the forums and there out put.

    httpd -t
    httpd: bad user name ${APACHE_RUN_USER}

    apache2 -t
    apache2: bad user name ${APACHE_RUN_USER}

    Any help would be great as I am a newbie and this sever is for learning and testing so starting over would not be a problem but I would rather get guidance to figure out what I did wrong..
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Ganther

    Ganther New Member

    I will retry that Till but that is when it stoped working for me I will give it another shot when I get home today
  4. Ganther

    Ganther New Member

    I changed the user name as indicated in the link you provided
    User www-data
    Group www-data

    made these changes to /etc/apache2/apache2.conf

    Now when I run restart apache it still fails

    When I run httpd -t and apache2 -t both get Syntax OK

    Any suggestions
  5. Ganther

    Ganther New Member


    This is what I found. keep in mind I am new and learning so let me know if I am on the right track.

    checked the apache2 error.log this is what it has in it

    unable to start piped log program ' /usr/sbin/vlogger -s access.log /var/log/ispconfig/httpd': No such file or directory

    I was able to get apache2 to start by commenting out this line in the apache2.conf

    Include /etc/apache2/sites-enabled/

    Now when I start apache this is the msg I get

    [email protected]:/etc/apache2# /etc/init.d/apache2 restart
    * Restarting web server apache2 [Fri Feb 06 23:33:07 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Fri Feb 06 23:33:08 2009] [warn] NameVirtualHost *:80 has no VirtualHosts

    [ OK ]
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if you mixed up several setups. You installed ispconfig 3 on a server that was installed as described in the perfect setup guide which is completely incompatible and installing ispconfig 2 on a server were ispconfig 3 was installed before is not possible too. You will have to format the server and then decide which version you want to install and configure your server for that without mixing ispconfig 2 and 3 setups.
  7. Ganther

    Ganther New Member

    Till your right

    sorry I did not mention this first. I did try to install ispconfig3 rc1 first it didn't install correctly I tried to remove it guess I did not do it correctly then I installed ispconfig2.

    I have reinstalled the Ubuntu 8.10 following the perfiect setup guid.

    Which version of ispconfig should I use then 2.2.29.

    I have one other question. This is being used for internal learning purposes so my family can learn to design website. I want to create 3 domains such as www.mydomain1.com, www.mydomain2.com, www.mydomain3.com accessable on the intranet.

    do I need to assign more than 1 ip address to the nic so I don't get shared IP page? or will ISPconfig take care of that?

    Thanks for the help Till
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You need just one IP. But you will have to access the sites by domain name and not IP. Sites in ISPConfig can not be accessed by IP address.
  9. Ganther

    Ganther New Member

    Ya I figured I would have to access the site by domain. which version of ISPconfig should I use since I followed the perfect setup guid for ubuntu 8.10.? or does it realy matter since this is for learning..
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.29 as ISPConfig 3 is incompatible with this guide.
  11. Ganther

    Ganther New Member

    Thanks for all the help Till

Share This Page