APS Installer failing

Discussion in 'Installation/Configuration' started by chris weinhaupl, Jan 4, 2019.

  1. APS applications are visible in 'update package list'

    Under available packages:
    Wordpress 5.0.2-260 Web/Blog Yes
    GO through the steps in to install
    Installation: WordPress 5.0.2-260
    No task is created to start the wordpress installation

    I have build Debian 8,9 Ubuntu 16,18 and tried manual install and script install of ispconfig
    We working on one of my other machines until I upgraded to Debian9 then the APS installer stopped working.

    I tried the debugger but there are no tasks to see the errors
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use the current ISPConfig version 3.1.13?
  3. Yes

    ISPConfig Version: 3.1.13
  4. I have tried the install again on my vmware servers using public distros.
    I was doing the installs with linode distros
    I found that that the public distros appear to work
    The linode distros maybe the problem.

    Just sharing my thoughts.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, quite strange. When no job gets added at all, then this probably means that the mysql insert query for the job jailed. So possible next steps might be to enable query logging in mysql and to compare the php and mysql settings between a linode system and a normal distro install.
  6. OKay
    I logged this mysql statement
    after there is no job to install

    # Time: 2019-01-07T06:57:41.866904Z
    # [email protected]: ispconfig[ispconfig] @ localhost [] Id: 242
    # Query_time: 0.000691 Lock_time: 0.000304 Rows_sent: 1 Rows_examined: 161
    SET timestamp=1546844261;
    SELECT id, name,
    CONCAT(version, '-', CAST(`release` AS CHAR)) AS current_version
    FROM aps_packages
    WHERE name = (SELECT name FROM aps_packages WHERE id = '127')
    AND package_status = 2
    ORDER BY INET_ATON(SUBSTRING_INDEX(CONCAT(version,'.0.0.0'),'.',4)) DESC, `release` DESC LIMIT 0,1;
  7. I built an image on Digital Ocean and have the same issue.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The above is just a select query, there should be an insert query when you choose to install a package.
  9. so i am thinking the insert statement wasn't created.
  10. I have recreated the issue again on the hosted platforms Digital Ocean and Linode.
    I dont have the issue when I create the VM on my local servers in VMWare and in VIrtualbox.
  11. Might there be some additional thoughts?
    Can I collect any new data?
    I can create a lab for testing.
  12. I have tried EDGE, Firefox and Chrome
    all the same result
    no task is created
  13. I tried the FQDN URL and IP Address
    same result
    no task created
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that this is browser related. If it works in your local vm but not on Linoder or Digitalocean, then there must be a difference in server config that causes this, in my opinion.

Share This Page