APS Installer not installing packages after Update

Discussion in 'Installation/Configuration' started by ClaudioP, Dec 21, 2016.

  1. ClaudioP

    ClaudioP New Member

    Hello Guys,
    My system is Ubuntu 14.04
    The ISpconfig version is 3.1

    have any of you gone trhough this?i´ll try to describe here what is happening to me.
    I have updated ISPCONFIG to the latest version available, ane everything works fine, except what is described below:
    - Objective -> Install Wordpress
    - Previous History -> aps Installer was working just fine with three domains with Wordpress installed working and very good
    - Actual History -> whenever i try to install a new Wordpress package through Aps Installer it will go through every step and when i click to install it, i wont install anything, no task appear, but also no error is given
    - What i´v tried:
    1 - Emptied the Aps_Instance Table
    2 - Emptied the aps meta folder
    3 - Resynced
    4 - Updated the package list
    5 - Rebooted the server
    The result was that now despite the fact that every single one of my sites is perfectly working i cant see the previous installations listed on Aps Installer -> Installed Packages, plus the previous error persists, also i found out that the "/usr/local/ispconfig/server/aps_packages" is empty
    Now i´m out of ideas about what could be happening, could any of you suggest something?

    Thank you all in Advance
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I've added a bugreport for that here: https://git.ispconfig.org/ispconfig/ispconfig3/issues/4390

    There have been 2 other users that reported this behavior but we could not reproduce that here yet. It might be that a field in the database in one of the aps* tables is missing e.g. because it could not be added during update or maybe one of the tables is reported as broken on your server. What you can try is that you compare the aps tables from install/sql/ispconfig3.sql file (in the ispconfig3 tar.gz) with the table layout in your database and check your database tables with phpmyadmin to ensure that none is marked as crashed.
  3. ClaudioP

    ClaudioP New Member

    Well, i´m going to clone this one and investigate it further later on, but, as for now the fastest route for me is to install another server and transfer the sites, because i´m in a really tight spot here, but anyway, cloning will be fast here and this issue really, really made me curious.
    I´ll let you know what came out of further investigations, maybe that could help with preventing it from happening again.
    Thank you my friend
  4. ClaudioP

    ClaudioP New Member

    Well, unfortunately after installing a brand new server(using the latest Stable Version) and migrating all websites to this new server, the same thing happens...so i believe that it is related to this new version and not the upgrade like i was thinking before.
    i have checked and even after updating the package list etc and etc i have 2 empty tables:
    and 2 tables filled with data:
    I have installed ISPCONFIG on a VM inside my computer using the exact same version of everything, and is works normally, not a single problem...at all.
    The production one is hosted on AMAZON, could that be causing a problem?
    Last edited: Dec 22, 2016
  5. gody

    gody Member


    I encountred some trouble with the APS installer when I use the ISPConfig API.
    In mono server setup, all was good.
    But in multi server setup, CMS who need database like wordpress isn't deploy.

    I think the problem is arround the "client limits "

    When I add a new client the default_dbserver is 0, but the only db_server availbale in my setup have id 2.
    And yes, the db_server is properly set inside into "system -> main config -> sites -> Default database server"

    The APS module check if the default_dbserver is a mysql server
    In my case the server 0 isn't a db server ... so the installation fails without error

    Maybe use the db_server instead of default_dbserver inside the aps_guicontroller.inc.php

    Configurations: Multi Debian 8 / ispconfig 3.1.1

    My 2 cts,
  6. Stephan Ververda

    Stephan Ververda Member HowtoForge Supporter


    I seem to be having the same problem with a new installation, and it's gody's reply that made me realise what the problem might be and it's now reproducable also. The topic starter never mentioned wether he was having the problem in a multi-server setup or in a single-server setup, but as gody mentions it seems to be related to where the db server resides and wether or not the webserver where the package is to be deployed has the role of db server or not.

    My configuration: Multi Debian 8 / ispconfig 3.1.3. the master server has the roles of web, mail, ftp and dns, and i have one secondary server with the roles of db and dns.

    In the above setup i have in the system/main config/site as default webserver wh004.its-provided.com (master server) and as the default DB server wh005.its-provided.com (secondary server).
    Now when i go to install a package that uses a DB (wordpress in this case), after filling in everything and selected install package i get returned to the installed packages immediatly and nothing happens.

    As soon as i give my masterserver also the role of DB server, but i leave the secondary server as default DB server, the package gets installed correctly, however with the DB created on the master server and not on the secondary server.

    And for the topic starter: the "/usr/local/ispconfig/server/aps_packages" folder remains empty until you are actually able to install a package (so it's not filled upon updating the packagelist). And it looks like the installer first does a DB check before doing anything else, fails so it won't even download the installer package.
  7. niedermannator

    niedermannator New Member


    Have a look at your servers and find out the id of your dbserver using the following sql-command:
    select server_id,server_name from server;

    Then (if you have only one dbserver which has for example id 4) update the client table and set this id the default_dbserver id for all clients:
    update client set default_dbserver=4;

    Then retry to install packages... at least for me this works --> Installation_success

    Cheers Andi
  8. rob_morin

    rob_morin Member

    This worked like a charm for me!
  9. quartist

    quartist New Member

    We have two db servers with id: 4 , 5.
    When I create a client, every time default_dbserver = 0. How to correct this? It is possible to change a client creation script to form:
    db_servers = default_dbserver ?
    Crons with client update are not solution!
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use client limit templates? If yes, did you set the db servers there?
  11. quartist

    quartist New Member

    yes. dbserver is correct. After create client with limit templates db_server = corrent server ID.
  12. quartist

    quartist New Member

    in DB this look like this.
    We need the same ID for server and default server.

    Attached Files:

Share This Page