APS packages not installing from available list

Discussion in 'Installation/Configuration' started by BoldForester, Oct 10, 2016.

  1. BoldForester

    BoldForester New Member

    OS: Debian Jessie x64 (fully updated, from public Amazon EC2 AMI)
    ISP Config 3.1
    Configured according to https://www.howtoforge.com/tutorial...-8-4-jessie-apache-bind-dovecot-ispconfig-3-1, no BIND (using DHCP EC2 DNS), some optional components not installed.
    EC2 network config allows full outbound access and only access to the important ports for the server (22, 25, 80, 110, 143, 443, 8080).

    Everything is fine with setting up clients, domains, e-mail users, servers, let's encrypt. E-mail flows in and out. Everything looking healthy.

    I am trying to install an APS package. As admin, I go to update package, and all packages download OK to show a full list of packages. I then go through the installation options for several packages, but the packages do not install - no database creation, no error, nothing in the logs with debug on. This looks very similar to the first part of the following: https://www.howtoforge.com/communit...t-installing-packages-no-error-message.65203/
    When I look at the dbispconfig database with phpmyadmin, the aps_packages table has 163 entries (as expected), aps_instance_settings and aps_instances no tables.
    The directory /usr/local/ispconfig/server/aps_packages is empty, with owner root:root
    I tried changing the permissions to ispconfig:ispconfig and re-updating the list (delete from table aps_packages first). No good.
    I tried to manually download the .zip for an aps package from the URL given in the aps_packages table, set the permissions. No good.

    Now I'm stuck. Any thoughts? I'd really like to install osticket and one or two other packages from APS. i know I can do it manually as a work around, but it'd be much easier and more elegant via APS.


    Attached Files:

  2. BoldForester

    BoldForester New Member

    I should also add, I tested php curl to see if it downloaded from the internet and it worked no problem

Share This Page