Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456

Discussion in 'Installation/Configuration' started by ronee, Apr 5, 2009.

  1. ronee

    ronee Member HowtoForge Supporter

    Fresh install of Ispconfig on CentOS 5, things appear to be working however the ispconfig web interface periodically becomes unusable, only blank pages show up, cannot log in due to javascript errors and so forth.

    Restarting apache temporarily resolves.

    Also, the following repeatedly appears in /var/log/httpd/error_log:

    Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456, <STDIN> line 18

    I tried this:

    but no real difference, same error shows up in the error_log

    perl-TimeDate is installed

    which vlogger outputs: /usr/sbin/vlogger

    the above two items I have seen mentioned in other threads where the problem appeared similar.
  2. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
  3. cvladan

    cvladan New Member


    I had the same problem. For me, the right solution for this problem is to change only one letter %b from lowercase to uppercase in file /etc/httpd/conf/sites-available/ispconfig.conf,
    in LogFormat line. Change:

    LogFormat "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    to this
    LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig

    Lowercase b to uppercase B. It looks that vlogger does not understand dash - when it's zero it must be zero.
    As it is written here already:

    %B (Bytes sent, excluding HTTP headers),
    %b (Bytes sent, in CLF format i.e. a '-' rather than a 0 when no bytes are sent)

Share This Page