authdaemond: fork: cannot allocate memory

Discussion in 'Installation/Configuration' started by Mole, Jun 29, 2009.

  1. Mole

    Mole New Member

    Today I receive this error ir /var/log/mail (, mail.err)
    Jun 29 22:32:41 websrv pop3d: Connection, ip=[::ffff:_IP_]
    Jun 29 22:32:41 websrv authdaemond: fork: Cannot allocate memory
    Jun 29 22:32:41 websrv pop3d: LOGIN FAILED, user=user_name, ip=[::ffff:]
    Jun 29 22:32:41 websrv pop3d: authentication error: Input/output error
    Jun 29 22:34:55 websrv postfix/anvil[2524]: statistics: max connection rate 1/60s for (smtp:_IP_) at Jun 29 22:31:33
    So - nobody can login into their mail account! ;-(((

    With disk size all is OK... What else could be the problem?! :(
  2. Mole

    Mole New Member

    sorry, problem solved with:

    websrv:# authdaemond restart

    but - where was problem?
  3. Mark_NL

    Mark_NL Member

    Looks to me the server ran out of memory at that point .. how much ram you have? is it a VPS?

    authdaemond tried to start a child process which it couldn't because it couldn't allocate memory for it, so it stopped and gave the error in the logfile.

    When it happens again run:

    free -m
    you should be able to see the amount of memory you have - used - free

Share This Page