Automatic install on XFS fails on quota something

Discussion in 'Installation/Configuration' started by Taleman, Oct 24, 2022.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I used
    Code:
    wget -O - https://get.ispconfig.org | sh -s -- --no-mailman
    and it fails with:
    Code:
    . . .
    [INFO] acme.sh (Let's Encrypt) installed.
    [INFO] Installing packages quota, quotatool, haveged, geoip-database, libclass-dbi-mysql-perl, libtimedate-perl, build-essential, autoconf, automake, libtool, flex, bison, debhelper, binutils
    [INFO] Installed packages quota, quotatool, haveged, geoip-database, libclass-dbi-mysql-perl, libtimedate-perl, build-essential, autoconf, automake, libtool, flex, bison, debhelper, binutils
    [INFO] Adding quota to fstab.
    [ERROR] Exception occured: ISPConfigOSException -> Command mount -o remount / 2>&1 && quotaoff -avug 2>&1 && quotacheck -avugm 2>&1 && quotaon -avug 2>&1 failed. (/ispconfig.ai.php:15)
    [email protected]:/tmp# df -hT .
    Tiedostojärjestelmä Tyyppi  Koko  Käyt Vapaa Käy% Liitospiste
    /dev/sda2           xfs     6,3G  3,3G  3,0G  53% /
    [email protected]:/tmp# 
    Now I tried again, same host but root file system ext4 instead of XFS (and it is 28 GB instead of 6,3). Is it possible the automatic install fails when root FS is not EXT4?
     
  2. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    have you tried running the auto-install script using the --no-quota option when using xfs?
    i believe the quota settings in /etc/fstab are a little bit different for xfs, so maybe that is causing the problem.
    ie,
    where (on ubuntu at least) fstab has
    Code:
    usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0
    
    XFS uses:
    or maybe it's due to this:
     
    ahrasis likes this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's possible. Use the --no-quota option as @nhybgtvfr suggested and then configure quota in /etc/fstab after the install finished manually.
     

Share This Page