awstats and webalizer not working<

Discussion in 'Installation/Configuration' started by NixXxon, Jul 10, 2016.

  1. NixXxon

    NixXxon New Member


    i tried nearly every solution i found regarding to that problem but nothing worked for me.
    I get 404 with dropdownbox with "2016-07".
    In the backend under "Web --> Stats" it displays the table but with no real stats (0MB | 0 MB | 0MB | 0MB)

    Here is the output from the ispconfig-testscript:
    root@rs33131:~# cat htf_report.txt | more
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.6.20-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.20-0+deb8u1
    ##### PORT CHECK #####
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    ##### MAIL SERVER CHECK #####
    [INFO] I found the following web server(s):
            Apache 2 (PID 7390)
    [INFO] I found the following mail server(s):
            Unknown process (smtpd) (PID 21794)
    [INFO] I found the following pop3 server(s):
            Dovecot (PID 17879)
    [INFO] I found the following imap server(s):
            Dovecot (PID 17879)
    [INFO] I found the following ftp server(s):
            PureFTP (PID 26985)
    ##### LISTENING PORTS #####
    (only           ()
    Local           (Address)
    [anywhere]:21           (26985/pure-ftpd)
    ***.***.***.***:53              (30400/named)
    [localhost]:53          (30400/named)
    [anywhere]:22           (31677/sshd)
    [anywhere]:25           (21794/smtpd)
    [localhost]:953         (30400/named)
    [anywhere]:443          (7390/apache2)
    [anywhere]:993          (17879/dovecot)
    [anywhere]:995          (17879/dovecot)
    [localhost]:8999                (4641/php-fpm.conf))
    [localhost]:10024               (5610/amavisd-new)
    [localhost]:10025               (22345/master)
    [anywhere]:3306         (23990/mysqld)
    [localhost]:11211               (31118/memcached)
    [anywhere]:110          (17879/dovecot)
    [anywhere]:143          (17879/dovecot)
    [anywhere]:8080         (7390/apache2)
    [anywhere]:80           (7390/apache2)
    [anywhere]:8081         (7390/apache2)
    ##### IPTABLES #####
    The problem is that i cant access stats neighter in the backend nor via domain.tld/stats
    User / PW for */stats is set.
    output of
    root@rs33131:~# ls -la /var/www/awstats/
    -rwxr-xr-x 1 root root 676840 Dec 28  2013 /var/www/awstats/
    In /etc/awstats there is a config file for every domain as well as, awstats.conf, awstats.conf.local and awstats.model.conf.

    If you need further infos to help me please feel free to contact me :)

    I REALLY hope someone can help me. Also already tried dpkg-reconfigure awstats and webalizer --> helped nothing.

  2. NixXxon

    NixXxon New Member

    no ideas? ---> Still facing this problem.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the bind mounts for the log directories are missing in /etc/fstab or they are not active. Do you see the log files in the log dir of the website, e.g. /var/www/domain.tld/log/ ?
  4. NixXxon

    NixXxon New Member

    Thank for the reply. No i dont see any logfiles in that directory.

    output of fstab
    # /etc/fstab: static file system information.
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/sda1 during installation
    #UUID=3dc3b58d-97e5-497b-8254-a913fdfc5408 / ext4 errors=remount-ro,usrjquota=quota.user,,jqfmt=vfsv0 0 1
    # swap was on /dev/sda5 during installation
    #UUID=36bf486e-8f76-492d-89af-5a8eb3ce8a02 none swap sw 0 0
    #/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/hdv1 errors=remount-ro,usrjquota=quota.user,,jqfmt=vfsv0 0 1
    /var/log/ispconfig/httpd/domain1.tld /var/www/clients/client1/web1/log    none    bind,nobootwait,_netdev    0 0
    /var/log/ispconfig/httpd/domain2.tld /var/www/clients/client2/web2/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain3.tld /var/www/clients/client3/web3/log    none    bind,nobootwait,_netdev    0 0
    edit: I'm on a V-Server so no real devices to mount (I don't know if thats important)
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the affected domain listed there as a bind mount? If yes, try to run:

    mount -a

    and check the log dir again (you have to leave the directory with cd first, when you are inside on the shell)
  6. NixXxon

    NixXxon New Member

    Sorry for the late reply - so much todo here. :/

    All domains are affected and also the backend where i cant see any real stats.

    this is the output of mount -a:
    root@rs33131:~# mount -a
    mount: mount point errors=remount-ro,usrjquota=quota.user,,jqfmt=vfsv0 does not exist
    mount: permission denied
    mount: permission denied
    mount: permission denied
    The /log dir is empty and
    the /web/stats dir is empty beside of .htaccess, .htpasswd_stats and index.php
  7. NixXxon

    NixXxon New Member

    Any ideas? Would really like to get the stats working...
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess this is a vserver and your provider blocked bind mounts. Talk with your server hoster and tell them that bind mounts are not working on your server.
  9. NixXxon

    NixXxon New Member

    Thanks for the reply. My provider said: "The config of Bind-Mounts on Linux-V-Servers is not possible. Wich mount do you need?"

    Well i dont know what to answer --> Wich mount do i need?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig creates bind mounts dynamically for the stats folder of each website when the site gets created to make the log files accessible from within a chroot of the web folder while maintaining it to be in a central folder in /var/log/... which allows it to put them on a separate partition. You should consider using a hoster which does not use Linux vserver if it does not support bind mounts. Other virtualization solutions like OpenVZ, Virtuozzo, KVM, XEN, VMWare, Virtualbox (just to name a few) support it. Even in LXC it is configurable (but LXC should not be used due to lack of good quota support).
  11. NixXxon

    NixXxon New Member

    Thank you for the answer. Can you think of another solution than another provider? Or is this the only option on Linux V-Server?
  12. NixXxon

    NixXxon New Member

    Well seems like it wont work on my V-Server - What if anyone faces the same problem and does not want to change hoster. Here is what i did to "solve" the problem:

    I installed webalizer like i would without ISP-Config (here you can find a guide):

    Than i copied the config and logs from

    cp /etc/webalizer.conf /var/www/domainname/webalizer
    cp /var/log/ispconfig/httpd/domainname/access.log /home/clientname/logs/

    copied all that in a script and run it daily.

    Of course you have to edit config for every site manually once.

    Seems like it's working fine so far.

Share This Page