Backuppc .... again... sorry!

Discussion in 'General' started by Chris Williams, Jan 21, 2022.

  1. Chris Williams

    Chris Williams New Member

    Hi All.... I have a backup backuppc server working over nearly 100 linux based servers flawlessly, but on the test ISPconfig box, it just hangs the box at 100% CPU with rsync.

    There is nothing obvious in the logs

    Even an empty ispconfig box with no clients or websites just sits there forever rsyncing....

    What am I missing here? If backuppc cannot provide reliable backups of ispconfig boxes, we cannot use ispconfig.
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I'm not familiar with backuppc per se, but have never had a problem with rsync. What options is it running with? What files does rsync have open when it "hangs" (eg. use lsof -p)? If the cpu is maxed, it is obviously not hanging in the "doing nothing" sense, so using some of the verbose/debugging options in rsync or attaching with strace might give some clues.
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    BackupPC box or ISPConfig box?
    First time BackupPC makes backup of a host it takes a long time since all files need to be copied over. Next time it copies only changes, so much faster
    See the logs to figure out what is happening, and or start backup on the command line to see what it is doing.
  4. Chris Williams

    Chris Williams New Member

    The last test I ran sat at 100% cpu for 36hours and has not copied and of the var www sturcture.

    The command thats running is
    Running: /usr/libexec/backuppc-rsync/rsync_bpc --bpc-top-dir /var/lib/backuppc --bpc-host-name ispconfig.test.local --bpc-share-name / --bpc-bkup-num 0 --bpc-bkup-comp 3 --bpc-bkup-prevnum -1 --bpc-bkup-prevcomp -1 --bpc-bkup-inode0 2 --bpc-log-level 1 --bpc-attrib-new -e /usr/bin/ssh\ -l\ root --rsync-path=/usr/bin/rsync --super --recursive --protect-args --numeric-ids --perms --owner --group -D --times --links --hard-links --delete --delete-excluded --one-file-system --partial --log-format=log:\ %o\ %i\ %B\ %8U,%8G\ %9l\ %f%L --stats --checksum --timeout=72000 ispconfig.test.local:/ /

    I have tried it without the --one-file-system flag and it makes no difference. The log file just shows it looping endlessly with the client symlinks and mount points

    All of our other apache based boxes with literally hundreds of hosted sites do a first full in arouynd 30mins maximum, so after 30 hours I cant imagine its going to stop looping
  5. Chris Williams

    Chris Williams New Member

  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What have you set for
    It should have at least /proc and other subtrees where backing up makes no sense or have infinite amount of files.
    I still say you should
  7. Chris Williams

    Chris Williams New Member

    The solution to this problem by the way was that there were issues with using UnionFS when mirroring two servers. WE have abandoned this method of mirroring and switched back to using HA virtualization instead which has resolved the issue.
    Th0m likes this.

Share This Page