BackupPC Errors!

Discussion in 'HOWTO-Related Questions' started by handband2, Apr 19, 2007.

  1. handband2

    handband2 New Member

    I've setup three computers to backup with this howto.

    Two of the machines are linux the third is a windows machine. The windows machine backups perfectly. I created a seperate file for the windows to run samba. The two linux machines are running a that is backing up using rsync. The linux machines seems to see the server just fine with all the tests run within the howto. The problem I'm having is I'm getting the same error on both linux machines:

    Contents of file /var/lib/backuppc/pc/COMPUTER/XferLOG.bad, modified 2007-04-18 22:00:01
    Running: /usr/bin/ssh -q -x -l root COMPUTER /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group --devices --links --times --block-size=2048 --recursive -D --ignore-times . /home/
    Xfer PIDs are now 21979
    Got remote protocol 1953722184
    Fatal error (bad version): Host key verification failed.
    fileListReceive() failed
    Done: 0 files, 0 bytes
    Got fatal error during xfer (fileListReceive failed)
    Backup aborted by user signal
  2. handband2

    handband2 New Member


    The problem I had was fixed. This is how I fixed it:

    su backuppc
    ssh -l root 192.168.x.x whoami
    ssh -l root comuptername whoami
    Then to test it
    /usr/share/backuppc/bin/BackupPC_dump -v -f "computername"
    The howto should be noted that the FAQ in the documentation of BackupPC has ssh -l root clientHostName whoami to verify the command. Not ssh -l root 192.168.x.x whoami.

Share This Page