Discussion in 'HOWTO-Related Questions' started by emurray1122, Jan 12, 2007.

  1. emurray1122

    emurray1122 New Member

    I thought I'd posted this question and can't find it. I set up the ISPConfig server after using the Debian Setup. The installation went with no problem. Got back to the Intrusion Detection With BASE and Snort set up. Got to page 10....

    Next: BASE (Basic Analysis and Security Engine)

    Still in the download dir, we move the base dir into the 1st website map that you created with ISPconfig


    I don't have anything like that. What did I do wrong?

    Liz M
  2. edge

    edge Active Member Moderator

    I think (it's some time ago that I made that howto) that you can put it in any dir as long as it accessible through your web browser
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Did you create an initial website with ISPConfig?

    I think the sequence needs to be:
    1. Install ISPConfig
    2. Create / configure 1st website
    3. Install/ Configure BASE
  4. emurray1122

    emurray1122 New Member

    ISPConf then BASE

    I know, I know. I see lots of people sucessful. Not so for me right now. I thought I'd just re-install my ispconfig. I ran the uninstall. It can't find the mysql database.

    Where can I reset the database information in ISPConfig? I'm trying to find some kind of config file. When I couldn't find that, I thought...well, let's reinstall so I know everything lines up. Not so.

    When I tried the http://servername/base-1.2.7/setup I get a script
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    if you want to manually remove the database you need to execute a mysql statement. See for more info. Shortcut:
    #mysql -u root -p
    Enter password: 
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 2591 to server version: 5.0.24a-Debian_9-log
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    mysql> drop database db_ispconfig;
    mysql> quit
    Have a look at the comment on the MySQL pages about privileges.
    Remember to remove the directories /root/ispconfig and /var/www/admispconfig (if you did not change the install directory in expert mode) also before re-installation.
  6. emurray1122

    emurray1122 New Member


    Looks like the issue could be PHP was not installed on Apache. Although it is installed on the ispconfig piece. Now I'm figuring that out. I found that suggestion on another thread.
  7. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig comes with its own Apache and PHP for the control panel on port 81. It has no influence on the way you configured your main Apache, so it's possible that PHP is missing for the main Apache.

Share This Page