Basic Proftpd/MySQL configuration

Discussion in 'Server Operation' started by Drek, Feb 5, 2006.

  1. Drek

    Drek New Member

    I'm trying to set up proftpd-mysql on Debian Sarge. I followed the tutorial on this site to a t, but it's still not working. I can get my client (FileZilla) to connect to the server, but it stalls at "waiting for welcome message". I don't have iptables, or any firewall installed on the server, it isn't live yet, I'm just trying to install and configure everything, get it working, and then secure it. I'm accessing it from within the lan. Is there another tutorial for setting up proftpd-mysql somewhere? I've done a ton of reading today, and my head hurts, and I can't see straight - do I sound like I'm whining? ;)
  2. falko

    falko Super Moderator Howtoforge Staff

    Have you tried both active and passive mode in your FTP client?
    Please post the output of
    netstat -tap
    Do you see any errors in the logs in /var/log?
  3. Drek

    Drek New Member

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     1993/mysqld
    tcp        0      0 *:www                   *:*                     LISTEN     2172/apache2
    tcp        0      0 *:ftp                   *:*                     LISTEN     2073/proftpd: (acce
    tcp        0      0       *:*                     LISTEN     2058/sshd
    tcp        0      0 *:https                 *:*                     LISTEN     2172/apache2
    tcp        0      0 *:3551                  *:*                     LISTEN     1869/apcupsd
    tcp        0    296        ESTABLISHED2590/0
    As for logs, is there supposed to be a proftpd log? I looked for one in /var/log and couldn't see one. The only mention I could find of proftpd was in daemon.log.

    As I said, this seems to indicate that I've at least connected.

    And yes, I've tried both active and passive mode.

    edit: Actually, I'm thinking maybe its a permissions problem. I haven't got any of that sorted out yet. I've got the right owership on the folder, but I'm not sure I've got the permissions right.
    Last edited: Feb 6, 2006
  4. falko

    falko Super Moderator Howtoforge Staff

    Have a look at /var/log/xferlog, /var/log/syslog, /var/log/messages.

    Have you double-checked all your configuration files that they look like the ones from the tutorial?
  5. Drek

    Drek New Member

    I moved on to finish my configuration of PHP and MySQL. I completely uninstalled ProFTPD. I'll try installing it again and get back here with any results. I'm just happy to get my website back up and running. At this point the FTP is secondary. :)

Share This Page