Bind: Configuration errors.

Discussion in 'Installation/Configuration' started by tomfmason, Feb 24, 2007.

  1. tomfmason

    tomfmason New Member

    I have fedora core 4 and I followed the Bind setup shown here and here is the error that I am getting when I attempt to start named.

    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/var/named/chroot/var/named/' failed: file not found
    /etc/named.conf:3: parsing failed
    line three of the named.conf is:

    directory "/var/named/chroot/var/named";
    I know that is a valid directory. Here are the permissions for it..
    drwxrwxr-x  4 root  named 4.0K Feb 23 00:07 named
    drwxrwx---  3 root  named 4.0K Feb 15 19:14 run
    drwxrwx---  2 named named 4.0K Mar 13  2003 tmp
    Any ideas as to what I did wrong or how I can fix it would be great..

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please execute these commands again:

    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot

    and try to start named.
  3. tomfmason

    tomfmason New Member

    Thanks for your response..

    Everything is fine until I get to this line
    ln -s ../../ chroot.
    when I execute that command I get the follow error.
    ln: `chroot': File exists
    I am starting to think about just removing bind and start over again. Will I also need to start over with ispconfig or?

    Thanks again,
  4. falko

    falko Super Moderator ISPConfig Developer

    That's ok. This means that the symlink is already existing which is fine. :)
  5. tomfmason

    tomfmason New Member

    I still couldn't get bind to start after doing that. So I removed it and ispconfig. I started over and now everything is working perfectly.

  6. cnicules

    cnicules New Member

    same isue


    i have the same isue, and to me it's strange to see in the config file the full path of the real system, as the config file is executed by named inside the chroot environment, so there is no /var/named/chroot.... there, a simple modif in the named.conf to the pid file location solved the problem, meaning /var/run/named/ (and he put it in the chroot env, not in the real system).

    The problem is that ipconfig keeps modifing the named.conf file each time i update something (modif to the pid location), problem solved by modifying the data base and the named.conf.master file

    my system is a clean centos4.4, named-chroot, postfix,proftpd
    no install errors of ispconfig 2.2.10

    hope that helps to make some more check on the install script to solve this problem, and i'll keep you posted if i find others

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can change the named.conf template of ISPConfig in the directory /root/ispconfig/ispc/conf/named.conf.master

Share This Page