Bind don't restart/reload

Discussion in 'General' started by crazyiven, Mar 20, 2017.

  1. crazyiven

    crazyiven New Member

    Hello :)
    After upgrading my ISPConfig to 3.1.2 (on Debian Jessie Servers) on Saturday i've noticed a strange error with BIND / DNS. I've a Main DNS Server (server1) and a Slave DNS Server (server2). The slave is marked "mirror of server1" in ispconfig and this worked great in the last years and still works, but the problem is:

    If I add a new record to a domain (lets say test.domain.tld) the new settings get written to /etc/bind/pri.domain.tld (i've checked), but if i use nslookup server1 dont know this record and server2 DOES know this record. If i reboot/reload bind9 by hand the record is active on server1, cause the zone file is correct.

    So the new record gets added to the database and the zone files of BOTH servers. But just server2 get the "reload" signal ... server1 just dont do it ... and that is a problem :). What can i check/do?

    Kind regards
    Last edited: Mar 20, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to use the debug log level in ispconfig to see why bind does not get reloaded.
    crazyiven likes this.
  3. crazyiven

    crazyiven New Member

    Dear till,
    I've done this and it seems there is a problem with systemd not with ISPConfig. I'll check this later (tonight) and will keep you posted. But it seems that ISPConfig is not the problem :)
  4. crazyiven

    crazyiven New Member

    Problem is solved :)

    It was a problem with Systemd/SysVini ... ISPConfig used "systemctl reload bind9.service", but systemd was not configured right. So the problem was not ISPConfig, it was a server error.

    Thanks for the help with debug log! Pushed me in the right direction :). Keep the good work up, you're great! You can close this Topic and mark it as solved ;)

    Kind regards

Share This Page