Bind slave servers issue

Discussion in 'Server Operation' started by ArcticFox, Mar 15, 2015.

  1. ArcticFox

    ArcticFox New Member


    I have an existing centos 6.6 server running webmin that hosts one website and DNS for that site. I have just recently obtained another centos 6.6 server which is running webmin as well as virtualmin, I have successfully linked my existing webmin server to my new server.

    I plan to use my new virtualmin server to host multiple websites as well as be the primary DNS server for these sites and make my existing webmin server the secondary DNS server. At this point I have added y existing server as cluster slave server on my new virtualmin server and the new master records I create sucessfully appear on my webmin server, however the records within side do not appear to copy across. If I click "test zone transfer" within one of the master records I get the following error:
    (Note I have replaced my real master IP address with below for secuirty reasons.)
    Testing transfer of slave zone from ..
    .. from : Failed : ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6_6.2 <<>> IN AXFR @ ;; global options: +cmd ;; connection timed out; no servers could be reached
    Originally I was getting an error that dig was missing so i fixed this by running "yum install bind-utils", I've tried to search for a couple of hours but I can't find anything obvious, I'm by new means a Linux, bind or webmin expert so I expect that it is something probably very obvious I have missed, any point in the right direction will be greatly appreciated.
  2. ArcticFox

    ArcticFox New Member

    ok I have solved this, turned out my firewall on my master server was blocking it,
    for anyone interested I fixed it by adding the following rule to Linux Firewall (iptbables)
    Allow If protocol is TCP and source is and source port is 1024:65535 and destination port is 53

Share This Page