Broken Fedora: Data recovery?

Discussion in 'Desktop Operation' started by Riff, Dec 31, 2010.

  1. Riff

    Riff New Member

    Good afternoon and Happy New Year coincidentally.

    I've been using Fedora for about a year now very happily but after upgrading from 12 to 14 and swapping out my graphics card in favour of a better one, I noticed I was having problems with the updater - some kind of kernel problem.

    I tried to back my data up at that time but my machine then crashed and refused to boot in to any kernels - it hangs at the point just before the login screen appears - I've got about 3 Kernels to try an it does it on all of them.

    I had an alternate hard disk so I popped that in the machine and put a fresh install of F14 (64 bit this time) on it, and having installed all the software I'm likely to need it's running nice now. However, I do want to save the data from my old drive.

    I've tried to add the old drive to the machine (being SATA I've just popped them on once the box has booted) but although I can mount the drive I don't seem to have permission to access the drive.

    Any suggestions as to how best to recover the old disk?

  2. Linusr@flanders

    Linusr@flanders New Member

    Recovery on the way...


    Two options:
    Mount the old drive if it is bolted into the box with the new one (two hard drives in the same machine) and use the file browser to copy-n-paste
    A cleaner method, one I've used more than once. Use tty Linux. Burn the ISO, bolt the old drive into the/a machine, boot from the CD, log in (instructions are on the screen) and mount the hard drive.

    to see what the drive is called


    to see where you can mount, and mount the drive

    and CD to the folder, have a look-see if everything is still there...

    Give the box a USB stick, mount the same as the drive (fdisk - mount)
    copy from one mount point to the other

    Good luck!


Share This Page