Broken site link

Discussion in 'Installation/Configuration' started by Davide, Mar 11, 2007.

  1. Davide

    Davide Member

    Hello all

    I have a broken link in /var/www. It's a reseller's website, then I don't know what caused this situation.

    This is what I have in /var/www about this domain

    drwxr-xr-x 8 domain.es_ftp web162 336 2007-02-12 12:09 web162
    lrwxrwxrwx 1 root root 15 2007-02-12 10:50 -> /var/www/web425
    drwxr-xr-x 3 root root 72 2007-02-15 00:30 (NOT a link to web162, NOT a link al all)

    "?" at second line's end of domain name is an special caracter, but NOT a question mark (it's shoew like ^I in mc". /var/www/web425 doesn't exist.

    I have looked at February 14 logs, and then there were the following links:

    lrwxrwxrwx 1 root root 15 2007-03-11 22:00 -> /var/www/web162
    lrwxrwxrwx 1 root root 15 2007-03-11 22:00 -> /var/www/web425
    Plus, there was a "web425". I suppose the problem appeared when ISPConfig tried to delete the "" link ehen they tried to delete erroneus entry...

    At February 15, then situation was the same as today.

    Domain is working OK, I have yesterday's logs in /var/www/, so I know it's using physical "/var/www/" directory to rotate logs instead of "web162". The last log in /var/www/web162/log/ is from february 14, 2007.

    Could I delete "", "" (saving current logs), and recreate link -> web162 without breaking ISPConfig?

    If yes. should I take care about something?
    I have
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that should not cause any problems. ISPConfig uses internally always the web[ID] folders except of the webalizer script, the symlinks are mainly for the admin to make the shell navigation easier.

Share This Page