BUG Report 2.2.30 - Co-Domains

Discussion in 'General' started by kextra1, Mar 24, 2009.

  1. kextra1

    kextra1 Member

    New version stable 2.2.30 has a bug concerning Co-Domains.

    I have created Co-Domains for users to access subdomains such as:

    admin.domain.org (forward tab: https://www.domain.org:81)
    webmail.domain.org (forward tab: https://www.domain.org:81/roundcubemail)
    mailuser.domain.org (forward tab: https://www.domain.org:81/mailuser)

    After 2.2.30 none of them work, they all omit :81 and forward to:


    with or without the slash.....

    I only have about 30 domains on my personal box....but my bosses servers have over 2000 domains configured this way.

    The only possible solution I can think of is to create a domain webmail.domain.com with it's on webspace which is unnecissary and ridiculous with an apache redirect to the webmail/admin/mailuser pages....but to do this for over 2,000 domains!!!

    Has anyone had this problem?....or is anyone smart enough to fix it?

    Thanks guys

  2. Hans

    Hans Moderator Moderator

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This bug has been fixed already and is in svn. Either you update your server to this version:


    or you take the tar.gz file and copy the file install_ispconfig/scripts/lib/config.lib.php from the tar.gz to the directory /root/ispconfig/scripts/lib/config.lib.php

    Then login to ispconfig, change a setting in one of the websites and then click on save.
  4. Hans

    Hans Moderator Moderator

    I just upgraded one system with the SVN version and the problem with co-domains seems to be solved now. :)
  5. kextra1

    kextra1 Member


    Hey thanks,

    Before I install...exactly how did u fix the problem?

    Any path, file or variables or line #'s heh or whatever would be helpful.

    Thanks again, I'll diff it

    ..oh wait just checked out ur link....u guys rock...gonna continue with u guys on my own servers.

    But still no luck....no luck going to Co-Domains webmail.domain.com

    forward to https://www.domain.com:81/roundcubemail

    forwards to https://www.domain.com/roundcubemail


    thanks guys
    Last edited: Mar 26, 2009
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I answered your question already in post #3 of this thread.

    You have to edit and change the settings of a website and then click on save to rewrite the apache configuration.
  7. kextra1

    kextra1 Member

    OpenSSL bug

    Maybe it could be an openssl bug?

    Because I just tried to submit an ISPConfig generated SSL Certificate to my RapidSSL provider and it said that the SSL certificate was to long

    same error i get on all my co-domains......

    ISPConfig 2.2.30
    Debian Etch 4.0
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Which details have you entered in the fields of the SSL cert? Most likely you entered a value which was too long or contained something that openssl was not able to handle.
  9. kextra1

    kextra1 Member

    SSL Cert

    Possibly, Thanks for the suggestion I will check that!

    It may be because I just bought a rapidSSL thing and when i tried to enter it in there it said too long.

    Also, I tried the:

    $domain["domain_weiterleitung"] .= strtolower($domain_weiterleitung_url_parts['host']);
    That Falko provided for me and I still got the error:

    Error code: ssl_error_rx_record_too_long

    However this error just started showing up when I upgraded to 2.2.30. I'd been using the same cert since 2.2.18 and never changed it...and it gave me the same error above after the upgrade.
  10. kextra1

    kextra1 Member

    Thank You Falko

    Actually I must have had an extra character or something in the config file because falko's solution worked.

    Thank you falko and till...lets not forget Hans the man...that guy is cool *bows down*

    respekt to u

    If I ever get out that way we should have a drink....i have my other areas of computer expertise, low level ASM and stuf like that but not much...take care and thanks again guys

    Because of you guys I got a better job! ...hehe go figure...much pr0pz

    Long Live The ISPConfig Krew! ... .. . ... . ... . . . . . b0h! b0h!


    Take care
    Last edited: Mar 27, 2009
  11. wr19026

    wr19026 New Member

    Any idea when 2.2.31 will be released? I want to fix teh problem but do not want to stay with the official releases
  12. falko

    falko Super Moderator Howtoforge Staff

  13. kextra1

    kextra1 Member

    I never saw this

    I never saw this bug

    can you please post the direct link since this forum post is old so i can read about it.

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    This has been fixed a long while ago. Update your ispconfig version to 2,.2.36. You should always keep your ispconfig system up to date.

    For details on chnages files for a bug, please see subversion log.

Share This Page