can not send mail

Discussion in 'Installation/Configuration' started by provell, Apr 25, 2006.

  1. provell

    provell New Member

    Hy everyone,

    I just did the "The Perfect Setup - Debian Sarge (3.1)"
    Then I dit an error free install of ISPCONFIG.
    Set up the correct ports on the firewall.

    All looked well until i tryed to send and receive email.
    Checking out the forum everyone had different problems.
    And at least they had error messages, I DON'T!!:confused:
    It is hard to troubleshout without error messages.

    Here is the thing:

    I am able te receive email from everyone outside my domain.
    I can send my self an email
    I can send other users in my domain an email.
    I can receive email from other users in my domain.
    But I can not send email to others outside my domain,
    to [email protected] for example.

    The big problem here is that the email is send, thus gets out of my outbox.
    But I do not get a send error or a "could not deliver" or some other error??
    It just disapeers???:eek:
    The same thing hapens when I use webmail (so it can't be a local setting on my desktop).

    I have checked the the mail.log and there I see something hapening but I can not understand it.

    websrv1 postfix/smtpd[1215]: connect from unknown[]
    websrv1 postfix/smtpd[1215]: 5B0D2D20C8: client=unknown[], sasl_method=LOGIN, sasl_username=scarto
    websrv1 postfix/cleanup[1218]: 5B0D2D20C8: message-id=<004a01c6687d$8888b860$9600000a@winxp>
    websrv1 postfix/qmgr[32679]: 5B0D2D20C8: from=<[email protected]>, size=1343, nrcpt=1 (queue active)
    websrv1 postfix/smtpd[1215]: disconnect from unknown[]
    websrv1 postfix/smtp[1219]: connect to[]: server dropped connection without sending the initial SMTP greeting (port 25)

    websrv1 postfix/smtp[1219]: connect to[]: Connection timed out (port 25)
    websrv1 postfix/smtp[1219]: 5B0D2D20C8: to=<[email protected]>, relay=none, delay=31, status=deferred (connect to[]: Connection timed out)

    Time out??
    I have disabled the firewall on the server and only use the ports in the adsl-router. port 25/tcp, 110/tcp and just to be sure 143/tcp.

    If anybody would be so kind to tell me where to find the anwser for this problem, I would be verrrrry thankfull!!:eek:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server hosted in a datacenter or on a DSL line?
  3. Hans

    Hans Moderator Moderator

    port 25 blocked ?

    It's possible that if your server is at home, your ISP is blocking your port 25.
    Which means that you can only send e-mail using the SMTP-server of your own ISP-provider. Like here in the Netherlands, most ISP's do so.
    The reason is an anti-SPAM policy.

    I do not say that it is your problem, but please check this out, it is good to know.

  4. provell

    provell New Member

    smtp handshake

    Hy geys, thanks for the response.:)

    Yes, I am using an ADSL line and a certified router.

    For the port isue I called my ISP and they sayd that the port should be open.
    The even tested this and were able to telnet directly on port 25 to my postfix server.
    So the port 25 blocked is defently not an isue here.

    I have done some checking myself on the SMTP connection and read about a SMTP handshake.
    My ISP is XS4ALL.NL.
    The gave me a host/DNS name of SCARTO.XS4ALL.NL
    I have named my server WEBSRV1 with the extension SCARTO.XS4ALL.NL
    Thus the whole dns string to reach my postfix server would be:

    This is dns string is not reachable from the internet and might be a problem for the "SMTP greeting (port 25)".:eek:
    I wil try to change my host name from WEBSRV1 to SCARTO and wil do the same thing for my domain name.
    (should have done that during installation of course)

    As this server is not setup with ISPCONFIG would you be so kind to tell me what config files I have to change to make this happen?
    Or is the advise to start all over again a better idea?:eek:
  5. falko

    falko Super Moderator Howtoforge Staff

    Then you must create a DNS record for WEBSRV1.SCARTO.XS4ALL.NL. Ask your provider to do so.

    If you don't want to create a DNS record for WEBSRV1.SCARTO.XS4ALL.NL, then you must edit /etc/postfix/, /etc/hostname and maybe /etc/hosts. Restart Postfix afterwards.
  6. Hans

    Hans Moderator Moderator

    XS4ALL is not blocking ports indeed.
    I have XS4ALL at home too
  7. edge

    edge Active Member Moderator

    XS4all (in Holland) is one of the few ISP's that still got all ports open (I also have XS4all)

    Also.. Make sure that you have a working SPF record if you send mail to Yahoo and or Hotmail.. If you do not have this, the email will never arrive!

    If you do have a SPF record, the email might (will) be in the 'bulk' mailbox, so have a look in there!

    Did you try emailing to a non yahoo/hotmail email address? If not.. Give it a test.. Your email might work fine!
    Last edited: Apr 26, 2006
  8. provell

    provell New Member


    Thanks for all the advise.

    I did some extra googling on the email-log messages.
    And it all came down to a closed port 25.
    Although I had a portforwarding rule on my router and it was reachable from the internet with telnet.

    So I thought what happens if I close the port(delete the forwarding rule).
    Ha!!! Same error messages in my log.

    So I went back to the shop where I bougt the router a few days ago and returned it.
    I got a brand new router, installed it, and.... ta ta ta !!! It worked.
    All the test mails that were still in my que were send.

    PFFFFF Wow

    Whel thanks anyway, I now have a beatifull ISPCONFIG running on my DEBIAN machine.
    thanks for the help all of you, hope to be of any help soon to.

    Rgds Edo

Share This Page