Cannot Access Control Panel after Install

Discussion in 'Installation/Configuration' started by firthusa, Jun 7, 2006.

  1. firthusa

    firthusa New Member

    I just finished entire install... the only thing I was not sure about was where it asked for the hostname and domain because I have not pointed any domains to the server yet so I left the hostname blank and and used the IP address for the domain which seemed to work... but now when I go: https://66.196.##.###:81 it just will not connect... I get the standard apache screen when I just type in the IP but I cannot access the control panel.

    Any advice? Also do you have any advice as far as securing the setup?

    Thanks, Nathan -
    Last edited: Jun 7, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to use firefox as browser when you connect. Firefox has more useful error messages in case the SSL cert is broken.

    Is your server behind a router in a NAT enviroment?
  3. firthusa

    firthusa New Member

    I used FireFox and it says: "This connection is refused". I am not behind a firewall or NAT envirement. This is a dedicated Debian server with my hosting company.

    Is there a config file that I could look at? Also by using the IP instead of the domain would that change anything? I could point a domain to it and see if that changes anything?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap


    iptables -L

    The vhost of the controlpanel is always configured to listen on all IP addresses on port 81, it does not matter which IP or domain you use as long as it points to your server.
  5. firthusa

    firthusa New Member

    Here is netstat -tap
    server1:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                    PID/Program name
    tcp        0      0 *:imaps                 *:*                     LISTEN     1                                             375/inetd
    tcp        0      0 *:pop3s                 *:*                     LISTEN     1                                             375/inetd
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     1                                             428/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     1                                             375/inetd
    tcp        0      0 *:imap2                 *:*                     LISTEN     1                                             375/inetd
    tcp        0      0 *:www                   *:*                     LISTEN     1                                             606/apache2
    tcp        0      0 *:ftp                   *:*                     LISTEN     1                                             593/proftpd: (acce
    tcp        0      0 server1.baronscu:domain *:*                     LISTEN     1                                             360/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     1                                             360/named
    tcp        0      0 *:ssh                   *:*                     LISTEN     1                                             367/dropbear
    tcp        0      0 *:smtp                  *:*                     LISTEN     1                                             564/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     1                                             360/named
    tcp        0      0 *:https                 *:*                     LISTEN     1                                             606/apache2
    tcp        0    300 server1.baronscusto:ssh adsl-69-232-73-4.d:4113 ESTABLISHED4                                             194/dropbear
    Here is iptables -L
    server1:~# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    I also just registered "" and "" as name servers with my IP's. This has not finished propegating but I'm not sure if that is whats causing it to not work. Are you required to have a domain assigned or can you simply run the server off of an IP?

    I really appreciate all the help!

    Thanks, Nathan -
  6. falko

    falko Super Moderator Howtoforge Staff

    ISPConfig isn't running. Please start it:
    /etc/init.d/ispconfig_server start
    You can use an IP address, but a domain is preferred.
  7. firthusa

    firthusa New Member

    Still not working

    Alright it now says "ISPConfig system is now up and running!" But it is still not working. I did notice a difference though. When I goto: it says:
    <H1>Bad Request</H1>
    Your browser sent a request that this server could not understand.<P>
    Reason: You're speaking plain HTTP to an SSL-enabled server port.<BR>
    Instead use the HTTPS scheme to access this URL, please.<BR>
    <BLOCKQUOTE>Hint: <A HREF=""><B></B></A></BLOCKQUOTE><P>
    <ADDRESS>Apache/1.3.34 Server at Port 81</ADDRESS>
    However when I go to the same address with "https://" then it still says "connection refused" so I dunno... definitly seems like somethings preventing HTTPS requests from working. Even if I try to access the website using HTTPS but without the ":81" I still get the same response. Any Ideas?

    Thanks, Nathan -
  8. firthusa

    firthusa New Member

    HTTPS Help?

    Which Protocol or program is responsible for HTTPS to work? How would I check to see if it is running or configured right?

    Also I noticed that ISPConfig did not automatickly start when I restarted the server, what would I do to have it automaticly start? Cause I know it's also asking for a mod_ssl password when it starts up so where would I place this?

    Thanks in advance for any help,

    Nathan -
  9. firthusa

    firthusa New Member

    Problem Solved!!!

    Problem Solved!!!

    Turns out I had an invalid SSL Certificate and I generated a new one and it worked :)

Share This Page