cannot access ispconfig web interface

Discussion in 'Installation/Configuration' started by spekkio, Aug 1, 2007.

  1. spekkio

    spekkio New Member

    So heres were i am, ive set up a functioning feisty fawn box according to this guide
    and i then installed ispconfig according to this
    it all works fine, but i did this on my LAN and the ip the server got was I then moved this server to another ip address, but it to had another router and i made sure it kept the same LAN ip of I then went into ispconfig and under server settings changed the host and domain to Now for some reason i cant access the web interface of ispconfig outside of the LAN, i try, and even the IP address and it still doesn't let me in. What it does end up doing is i get a error message saying. " has sent an incorrect or unexpected message. error code -12263" but if i try changing the adress to http, instead of https, i get a directory listing "Index of /" so i know somethings there. Anyway any help would be appreciated on how i can access ispconfig from outside the LAN.
  2. edge

    edge Active Member Moderator

    Do a search for 12263 on this forum, and you might find a fix.
    Last edited: Oct 27, 2007
  3. spekkio

    spekkio New Member

    ive gone through all the threads on that error code and im not finding something that will help, at best i think its just some ssl error. Anyone have any suggestions?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to access your server with http:// and not https://.
  5. spekkio

    spekkio New Member

    When i use i get a directory listing of "Index of /"
    so somethings still not right, i just want to be able to access the ispconfig web interface from outside the LAN its on. I have a dns entry for the server so when i ping it resolves to the WAN IP. In ispconfig ive set the
    hostname to servername
    domain to
    ip address to LAN ip

    so shouldnt i be able to put in and get to the ispconfig web interface? All the ports on the router are forwarded properly and im considering taking the router out of the picture and just using the wan ip.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you able to access the ISPConfig interface from within your lan?
  7. spekkio

    spekkio New Member

  8. spekkio

    spekkio New Member

    Well i figured out what i did wrong, when installing ispconfig i ended up encrypting the 2 rsa certs that you make with a pass phrase which is not what your supposed to do otherwise the ispconfig-apache doesnt start up properly on the system. It waits for you to enter the pass phrase :( So thats why i couldnt never access it from outside the lan.

    Thanks edge and till for all the help though.
  9. gillesdevals

    gillesdevals Member

    Same problem - but don't understand

    I have the same problem, can't access to webmail, error in return : 12263.

    I don't understand all the post regarding SSL Certificate.

    Example of the error :

    Is it possible to solve this problem simply ? with a detailed "howto"

    I installed Debian 4.0 with ISPconfig 2.2.18

    Thanks in advance for your help.

    Last edited: Dec 16, 2007

Share This Page