Cannot empty DNS recycle bin

Discussion in 'Installation/Configuration' started by yiannos, Aug 10, 2007.

  1. yiannos

    yiannos New Member

    Hello (I hope not everyone is on holidays) :) ,

    I have searched the forum and read all relevant articles but what is suggested up to now does not apply/work for me.

    I have deleted a client's website and I am trying to remove their domain name.

    All is being done through ispconfig interface.

    I delete the domain and it goes in the DNS bin. I then click on "empty recycle bin" and I am returned to the ISPconfig homepage (server status). When I return to the DNS bin (no matter how long I wait), the domain is always there looking at me with a irritating grin on its face :eek:

    I have not messed with the databse of ISPconfig in any way and I have not deleted any records manually from files yet.

    Thanks in advance.

    I just noticed that if I click on Empty and then return to the bin immediately, I do not get the ususal message that the bin is currently emptying and cannot be accessed etc. Instead, I am taken straight to the bin's contents (i.e. the damned record that is never deleted)

    PS I am using ISPconfig 2.2.15 on Centos 4.4 perfect setup
    Last edited: Aug 10, 2007
  2. yiannos

    yiannos New Member

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Check /home/admispconfig/ispconfig/ispconfig.log for errors.
  4. yiannos

    yiannos New Member

    OK I did a tail -f at the log and then clicked on "Empty recycle bin" at DNS.

    Nothing happened. No entry was added. The only entries in there are the actions taken at 23:59 every night.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    /etc/init.d/ispconfig_server restart

    Then wait a few minutes and try again.
  6. yiannos

    yiannos New Member

    Thanks for trying to help me!


    ~]# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!

    I waited for a couple of mins, checked the system was idle, and then pressed "Empty...." again. Unfortunately the same thing is happening.

    Keep it coming!!
  7. SamTzu

    SamTzu Active Member

    DNS problems

    I have noticed that you just have to repeatedly press the Recycle Bin icon for some time and then you get the deleted items in view. This is no big problem.

    The really annoying thing is when I added a domain that had a special characters in it like scandic ä or ö.

    I could not get it to work.
    I could not remove them permanently.

    Every time I tried somehow the DNS record poped up in /etc/bind/named.conf
    I removed it manually from there only to have it poping up again shortly.

    Really annoying.

  8. falko

    falko Super Moderator ISPConfig Developer

  9. yiannos

    yiannos New Member

    What exactly do you mean? To press the "Recycle Bin ont the left menu or the "Empty" link on the top right of the bin?

    Removing the entry from the file is no good as it is retained in the database and then the file is built by ISPconfig from the database entries. It must be removed from the web UI and not manually (I think)
  10. Gza

    Gza New Member

    I've got same error with recycle bin emptying

    the tail -f output is :

    21.08.2007 - 20:15:51 => INFO - Signalfile Set: empty trash

    but after reloading recycle bin, the entries are there like before emptying. (aka nothing happens)

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    It may take a few minuts, until the records can be deleted. ISPConfig will have to write the changes to the config files first.
  12. Gza

    Gza New Member

    ok, but the few minutes how many? ;)

    because, the entries are there now too :(

    and I see them in ispconfig database in del_state table too
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the sewrver part is not running. Run the command:

    /etc/init.d/ispconfig_server restart
  14. yiannos

    yiannos New Member

    I did another test today and I write here for completeness and in case it helps.

    I deleted also other DNS records as part of periodic maintenance. So now my RB had more than one records inside: the ones I deleted today, and the one that refuses to be removed from in there (grrrr). I then emptied the bin and all records were gone. EXCEPT for the one that refuses to be removed from in there (grrrr).

    So I am back where I started from, but with one more test done...:)
  15. yiannos

    yiannos New Member

    Further to the above, I just noticed something else:

    Instead of trying to remove the record from my DNS recycle bin, I restored it my surprise...the record is not a dns record. It is a weird looking site record. Wieird because:

    a) it is inside the DNS Manager tree
    b) All its labels are in German (I use ISPconfig in English)

    Note that the record is the website that corresponded to the DNS record I am trying to delete.

    I should repeat I have never messed with the database manually or otherwise.

    I now tried to alter this record and save it and I got this error:
    Last edited: Aug 22, 2007
  16. reinier

    reinier New Member

    Got the same thing. I think (as a hint) i created a website under a reseller that has ran out of users or domains. That did not create the site, but did create this DNS record (which is not a DNS record at all).

    yiannos, got any succcess?
  17. yiannos

    yiannos New Member

    Unfortunately not...

    I am afraid of altering the database as it is striclty not recommended by the developers.

  18. yiannos

    yiannos New Member


    I really need some help on this guys.

    The problem has occured on a registered domain name and now I cannot use it as the system will not let me create any dns record with this name. It says the domain name is in use although I have deleted it (but it stays in the recycle bin).

    So I ended up with a domain name I have paid for but I cannot use. I am not trying to assign responsibility for this to anyone else but myself -dont get me wrong-. I just need help.

    Thank you
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    You seem to mix up DNS and website domains. These two parts are completely independant in ISPConfig, so a existing entry in the dns manager can never prevent the creation of a website domain. Make sure that you delete the domain in the ISP-Manager and dns-manager and then empty the recycle bin's in both modules.
  20. yiannos

    yiannos New Member


    Thank you for your answer.

    No I do not mix up domains and DNS. I have done what you suggest. There is some serious mistake in my database as in the DNS container appears a website domain record (and whatsmore it appears in German)! I am attaching a screenshot for your reference.

    Attached Files:

Share This Page