Cannot login to ISPConfig3

Discussion in 'General' started by gcambull, Jan 29, 2009.

  1. gcambull

    gcambull New Member

    Not sure what happened, I had it running ok earlier, then when I tried to enable the mail settings it locked up, so I reboot the server. Now I try to login in and it says it cannot find it, says unable to establish connection.??
  2. gcambull

    gcambull New Member

    ok I went to server and typed: netstat -tap and I didnt see the httpd on, so I tried to restart and it gave me failure stating that syntax was wrong in line 37 of /etc/httpd/conf/sites-enabled/, invalid command "FCGIWrapper" perhaps misspelled or define by a module not included in server config.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that you selceted fcgi for php in thatw ebsite but missed to install mod_fcig in your apache server. To fix this, install mod_fcgi from your linux distribution.
  4. gcambull

    gcambull New Member

    Thanks Till,

    I am working with CentOS 5.2 and am noobie at it. how would I go about aquiring and installing the mod_fcgi? I tried the yum install mod_fcgi but that didnt work, then did a search for it and found it at the and downloaded on my regular PC, but how do I get it to the server (text based)?

    Thanks for the help.
  5. till

    till Super Moderator Staff Member ISPConfig Developer


    yum search fcgi

    to find the name of the centos package that has to be installed.
  6. gcambull

    gcambull New Member

    Last edited: Jan 30, 2009
  7. falko

    falko Super Moderator ISPConfig Developer

    I've written a tutorial about this yesterday which I will publish in a few days. Here's an excerpt:

  8. gcambull

    gcambull New Member


    Sorry it took me a while to reply. This is good news, when will the tut be ready to read, or is that the whole enchilada.

    I have since re-installed CentOs 5.2 to the whole hd, since I couldnt do anything about the wipeout I did with enabling fastcgi, when I didnt even have that installed. Maybe there should have been a small do the how to, after all i am a noob and us noobs tend to push buttons that we shouldnt push, hah reminds me of when I was training BigTruck driver noobs, they would touch a button/switch and I would yell NO! LMAO

    anyways, I didnt have too many errors re-installing ISPConfg3, though I will post them in a new thread, or search first.

  9. falko

    falko Super Moderator ISPConfig Developer

    In a few days. :) But my previous post shows how you can install mod_fcgid on CentOS.

Share This Page