Cannot login to phpmyadmin

Discussion in 'HOWTO-Related Questions' started by atjensen11, Aug 31, 2009.

  1. atjensen11

    atjensen11 New Member

    I had followed the Perfect Server with ISPConfig3 tutorial for Debian Lenny.

    Last week, I had an issue with phpmyadmin. Everytime I visited the site, there were strange characters in the username filed. Despite deleting them and typing in the correct credentials, the login always failed.

    I double checked that I could login to MySQL on the command line with the same credentials and that worked.

    In an attempt to fix the problem, I uninstalled and reinstalled phpmyadmin. It appears that I may have a different problem now. Whenever I browse to the phpmyadmin site, I get an error. The text above the area where the login credentials would appear says the following:

    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.
    In the box below this text, is another more specific error message. It reads:
    MySQL said:  
    #1045 - Access denied for user 'root'@'localhost' (using password: NO) 
    Please note that I get these errors just by browsing to the phpmyadmin page. There are no fields presented to me as the user to even enter the user and/or password. It appears to me at least, that phpmyadmin is trying to automatically login to the site as the root user without a password, which obivously won't work.

    Again, I can login to MySQL on the command line. Any suggestions?
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check the authentication settings in phpMyAdmin's config.php file.
  3. atjensen11

    atjensen11 New Member

    A short while after submitting my post, I found information online regarding the phpmyadmin configuration file.

    After the reinstallation, the authentication type was set to "config". I changed it to "cookie" and the phpmyadmin login screen began to operate again as I expected.

  4. longvnit

    longvnit New Member

    Config $cfg['Servers'][$i]['auth_type'] = http after login with your username and password.
    $cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?
    Last edited by a moderator: Sep 1, 2009

Share This Page