cannot mkfs.xfs /dev/sda2 on Ubuntu Server 8.10

Discussion in 'Installation/Configuration' started by jonniefive79, Dec 5, 2008.

  1. jonniefive79

    jonniefive79 New Member

    I have Ubuntu server 8.10 [64-bit] on a RAID 10 Array (amlost) I followed the guide to partioning my HDDs found here and all was well until I tried to follow the guide for Minimal Ubuntu Server Install I get
    mkfs.xfs: cannot open /dev/sda2: Device or resource busy
    when I enter
    mkfs.xfs /dev/sda2
    I have partitioned [4] 1TB drives just like the guide says using cfdisk:

    -sda1 50MB boot; sda2 999000MB Linux raid autodetect; sda3 1000MB swap
    -sdb1 999000MB Linux raid autodetect; sdb2 1000MB swap
    -sdc1 999000MB Linux raid autodetect; sdc2 1000MB swap
    -sdd1 999000MB Linux raid autodetect; sdd2 1000MB swap

    Any ideas what I need to do?
  2. sjau

    sjau Local Meanie Moderator

    as it is a raid now you can't access it by /dev/sda2... you need to address the according mapper... very likely it will be /dev/md0.... but you'll have to verify that.
  3. jonniefive79

    jonniefive79 New Member

    OK I see where there's a problem now.

    Here's what I did

    mkfs.xfs /dev/md0
    ln /dev/md0 /dev/sde
    The guide said to do this, what do I do now. Sorry I'm a noob.

  4. Swami

    Swami New Member

    Unable to find a way to part as xfs


    Please help me in creating a volume with xfs.

    I tried the below cmd with no luck!

    CentOS release 6.4 (Final)

    mkfs.xfs /dev/sdb2
    -bash: mkfs.xfs: command not found
    [[email protected] 1-500]#

    Thanks in Advance,
    Last edited by a moderator: Feb 1, 2015

Share This Page