Cannot open ISPConfig panel

Discussion in 'Installation/Configuration' started by Pulver, Feb 14, 2016.

  1. Pulver

    Pulver New Member

    I have been running ISPconfig for a couple of years without any problems.

    Suddenly I cannot longer browse to ISP config control panel.
    I have tried to run the script, checked that apachae is running. ( It feels like the apache virtual host for ISPconfig went missing)
    The system can still send and receive mail, but I can no longer control it!
    Please advice.
  2. Well-Known Member HowtoForge Supporter

    Did you do any changes / system upgrades? What operating system are you using? What were the last actions you remember before it failed?
    Check if your files are in its place
    ls /etc/apache2/sites-enabled/
    000-apps.vhost 000-default.conf 000-ispconfig.conf 000-ispconfig.vhost

    When you try to access ispconfig, what goes to your apache access and/or error log?
  3. Pulver

    Pulver New Member

    Debian (uname -mrs : Linux 3.2.0-4-686-pae)
    ( I also use webmin for other purposes) I haven´t been poking around in ISPconfig for about a month, and I think I have updated some system files through webmin since then.
    The files in sites-enabled are there.

    apache2 error log: ( when starting apache2)
    [Sun Feb 14 19:23:15 2016] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Sun Feb 14 19:23:15 2016] [error] python_init: Python executable found '/usr/bin/python'.
    [Sun Feb 14 19:23:15 2016] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.

    No log entries when i try to connect
  4. Well-Known Member HowtoForge Supporter

    The errors are not related, what about the access / other-vhosts access logs?
    Do you get a 404 or similar when trying to connect to ISPconfig on port 8080?
  5. Pulver

    Pulver New Member

    no related entries in access/ other-vhosts log files. ( some entries regarding port 80 but thats not relevant)
    browsers says "unable to connect" ( I have ISPconfig set up on port 81)
  6. Well-Known Member HowtoForge Supporter

    There we go =)
    What's $ netstat -npl | grep 81 saying?
    Firewall configuration by any chance?
    Can you reach it locally by just wget https://localhost:81 maybe?
  7. Pulver

    Pulver New Member

    Firewall is turned off
    netstat says that nothing is listening on port 81.
    and obviously connection is refused when trying wget to localhost on port 81!

    It feels more and more like my initial thought is correct : the virtual host for ISPconfig wont work
  8. Well-Known Member HowtoForge Supporter

    You can try to add some garbage to your 000-ispconfig.vhost and check if it's beeing parsed ( apache2ctl -t )
    If so, take a look at it - maybe post it's contents.
    And yeah, if no one's listening - it won't work - maybe ispconfig did a rewrite of the config and it's back to 8080?
  9. Pulver

    Pulver New Member

    no its still on port 81

    root@mail:/etc/apache2/sites-enabled# apache2ctl -t
    [Sun Feb 14 20:23:18 2016] [warn] NameVirtualHost 192.168.#.#:0 has no VirtualHosts
    Syntax OK
  10. Well-Known Member HowtoForge Supporter

    So you tried adding some random garbage to the ispconfig file, then ran apache2ctl and it doesn't complain?
    If so, it doesn't parse / include needed files from sites-enabled!
    check your apache2.conf in /etc/apache/ for
    IncludeOptional sites-enabled/
  11. Pulver

    Pulver New Member

    sites-enabled was disabled (#)
    removed it an I got an error from apache , du to my junk in ispconfig.vhost file .
    Removed the junk and it all fired up..
    Thanks a million!

Share This Page