can't acces smtp

Discussion in 'General' started by melandr, Nov 17, 2005.

  1. melandr

    melandr New Member

    Hello i can't access smtp from outside of server. When I use webmail all work fine. I can log to smtp by telnet but again only from localhost. I firewall a have smtp alowed . What i can do about it . And sory for my bad english M

    P.S.: I searched in forum but i didnt't find answer

    and also i Have problem with webalizer. i can't find stats and in ispconfig there are no stats again everywhere are zeros

    again i listed forum but any answer didnt helped me :(
    Last edited: Nov 17, 2005
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is yourserver in a NAT enviromet or does it have an internet IP in a datacenter?


    1) is webalizer installed on your server?
    2) The stats are generated nightly, so you may have to wait up to 24 hours until you can access them.
  3. melandr

    melandr New Member

    PC is in the Datacenter (configured by perfect setup debian sarge) and webalizer is installed (and i waited for 2 days to be sure) where i will find stat's xxxx/stats there is nothing . i don't know what is wrong :( i checked all ( what i find)
    but i'm noob to linux so every help will be usefull
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run this on the shell:

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php

    Did you get errors, are the webalizer stats being created?


    what output do you get for the command:

    netstat -tap
  5. melandr

    melandr New Member

    this is for webalizer ( i dont speak german at all )

    and nestat -tap

    realy THX for helping me
  6. falko

    falko Super Moderator Howtoforge Staff

    Regarding your SMTP issue: did you use the IP address or a domain name to connect to the server? If you used a domain name, it might be a DNS issue (DNS record pointing to the wrong IP address).
  7. melandr

    melandr New Member

    i ret it already i folow the steps but in crontabs i dont see anything wrog so i didnt changed anything and to my smtp server i tried name and ip adress also i tried to connect by telnet from outside but failed . from localhost (where i'm loged by ssh ) is everything fine (again thx for helping me and sory for my bad english)
  8. falko

    falko Super Moderator Howtoforge Staff

    You don't have to change anything, just open the cron tab by running
    crontab -e
    and save it without doing any changes. Cron is a little bit pedantic about how the cron tabs are created.

    To me it sounds like a firewall issue. You have a public IP address for your server and tried to connect to smtp using that IP address, and it didn't work, right?
  9. melandr

    melandr New Member

    ok i save crontab :) i will see what will hapen

    to my problem with smtp , becouse we are testing i didnt started firewall yet and my firewall at home isn't it (i can send email via other server's) and yes it has public IP ( i can't imagine what can it be there is nothing in mail.log )
  10. falko

    falko Super Moderator Howtoforge Staff

    What's the value of inet_interfaces in /etc/postfix/ Should be all.
  11. melandr

    melandr New Member

    it is all i'm posting configuration of postfix maybe it will help

    P.S: and thx now i have stats for websites by webalizer by i dont know if it is done by cron or by me ( i runed the script) i will se later (really thx much )
    Last edited: Nov 18, 2005
  12. falko

    falko Super Moderator Howtoforge Staff

    I've just done a dig on Does your ISPConfig server have the IP address
  13. melandr

    melandr New Member

    yes it's our IP
  14. falko

    falko Super Moderator Howtoforge Staff

    A telnet to the smtp port of your server works fine for me:

    server1:~# telnet 25
    Connected to
    Escape character is '^]'.
    220 ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250-SIZE 10240000
    250 8BITMIME
    221 Bye
    Connection closed by foreign host.
    Is it maybe your workstation firewall/router firewall that blocks you?
  15. melandr

    melandr New Member

    if it is problem only with me it would be okay but customers cant connect :( thx for help

Share This Page