Can’t establish connection

Discussion in 'Installation/Configuration' started by EyeofChaos, Jul 21, 2018.

  1. EyeofChaos

    EyeofChaos New Member

    Posting this again here. I realized I posted this in the wrong section earlier.
    Working on google cloud instance, ubuntu 16.x.x
    Successfully loaded ispconfig.
    Trying to add first site.
    In ISPconfig: I made a database user, database, ftp and added site.
    I created DNS on google cloud instance.
    I pointed the NS to the google cloud DNS in GoDaddy and it has propagated for over 24 hours.
    I doublechecked passwords. I also changed the passwords to be sure. Still doesn't work.

    PROBLEM: When I type in the domain in the URL, I get ERR_NAME_NOT_RESOLVED
    I've tried to connect with FTP and SFTP and I get Can’t establish connection

    What can I try next?
    Note: this is my first time working with linux. I'm a beginner.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    In Ubuntu use command "whois yourhostname.tld" to see what name servers are used to look up information for that domain.
    In Ubuntu use command host to see what information about your domain those name servers have. In Windows the corresponding command is nslookup. Like so:
    host yourdomain.tld ns1.thenameserver.tld
  3. ISPConfig Developer ISPConfig Developer

    moved my answer over here:
    There's too much involved as you could hope for a simple answer.

    your domains nameserver need to be correct
    the nameserver should have the correct A or AAAA records to let you browse the destination
    your google cloud server needs to be configured properly since as I remember getting a route to the outside world is not very beginner-friendly.

    and we'd need more information to help I guess, you're going on the internet with the domain, no need to obfuscate it, maybe we can check what is wrong from here.
  4. EyeofChaos

    EyeofChaos New Member

    Thanks for responding. I had to install whois and it worked to that point. I was able to see the correct name servers (I think)
    I'm now looking up the second part as it told me there was no command "host".
  5. ISPConfig Developer ISPConfig Developer

    apt-get install bind9-host
  6. EyeofChaos

    EyeofChaos New Member

    Sure: I presently own 24 domain names and do shared hosting. I want to move everything over to google cloud or to amazon servers and manage everything myself. Obviously, that is a big order, but I'm going struggle through anyways.
    I'm working with a domain name I don't care about:
    I created a Virtual Instance on Google Cloud using the following. Also, here are my IP addresses. Don't worry, I'm not giving up sensitive info. I'm going to recreate everything once I figure this entire process out.

    ISPConfig Version 3.1.12
    Ubuntu 16.04 LTS
  7. EyeofChaos

    EyeofChaos New Member

    Duh. I used a capital H. Got it now: Here is what I got:

    Using domain server:

    I don't recognize that address though.
  8. EyeofChaos

    EyeofChaos New Member

    I did this: apt-get install bind9-host
  9. EyeofChaos

    EyeofChaos New Member

    Also, I looked up bind9-host and started playing with some of the commands.
    I used the dig command and I don't recognize those IP addresses either. Here are the results.
    root@ubuntu5000:~# dig; <<>>
    DiG 9.10.3-P4-Ubuntu <<>>
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 48398
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

    ; EDNS: version: 0, flags:; udp: 512

    ;; Query time: 146 msec
    ;; SERVER:
    ;; WHEN: Sun Jul 22 15:55:21 UTC 2018
    ;; MSG SIZE rcvd: 51
    Last edited: Jul 22, 2018
  10. ISPConfig Developer ISPConfig Developer

    nameservers are ok, no issue with that.
    however google nameservers refuse to answer for your domain, is it this you're doing / need to do?

    gcloud dns managed-zones describe
    should return nameServers for that domain, use these at godaddy
    dig A
    where you replace the ns-cloud-a1.... with one of the returned nameservers to get A record.
    Last edited: Jul 23, 2018
  11. EyeofChaos

    EyeofChaos New Member

    Ok, so I redid the DNS and updated the godaddy ns numbers. The Advanced feature to export the zone record no longer exists in the godaddy DNS Manager. So, I'm going to try to input the A record and CNAME manually.
    dig A I think works now. Not sure.
  12. ISPConfig Developer ISPConfig Developer

    it looked better as soon as you changed the nameservers to the correct ones. looks fine for a start to me
    Last edited: Jul 23, 2018
  13. EyeofChaos

    EyeofChaos New Member

    Thanks for all your help.
    Here is what solved the problem: I went to godaddy DNS, clicked advance and added the IP address to the IPV4 area with the host name of www and saved. Then waited about 3 hours and it just worked. That is after I make DNS Cloud service and added A and CNAME records in google cloud.

    Thanks for all your help.

Share This Page