Can't get php-fpm working

Discussion in 'Installation/Configuration' started by non7top, Oct 1, 2014.

  1. non7top

    non7top New Member

    So I'm trying to make php-fpm working on Centos6.5, I installed php-fpm and mod_fastcgi and disabled mod-php . But after that I'm getting 404 for php files. Strace shows that apache is trying to access that magic php5-fcgi-*-80-0000-default.tld file which does not exist.

    [pid  3511] stat("/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-0000-default.tld/index.php", 0x7fff5a947760) = -1 ENOENT (No such file or directory)
    [pid  3511] lstat("/var", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www/clients", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www/clients/client1", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www/clients/client1/web1", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www/clients/client1/web1/cgi-bin", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    [pid  3511] lstat("/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-0000-default.tld", 0x7fff5a947760) = -1 ENOENT (No such file or directory)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    And you did all that before you installed ispconfig? I just ask because the ispconfig installer is the script that initially configures all services on your server, so all software that you plan to use has to be installed before you run the ispconfig installation.

    If you install software afterwrads, then you have to run the ispconfig update.php and let it reconfigure services. and ensure that you installed everything exactly as described in the centos 6.5 perfect server guide.
  3. non7top

    non7top New Member

    I just tried the manual step-by step, except that I didn't compile php by myself and didn't use custom php versions, instead I used the php-fpm package and additionally installed the mod_fastcgi(though this is not described in the guide, I guess it is required because of <IfModule mod_fastcgi.c>). Still getting 404 error.
    Appears I get the php-fpm daemon properly configured, but apache doesn't seem to even try to connect to it.

    In error log I get
    File does not exist: /var/www/clients/client0/web1/cgi-bin/php5-fcgi-*-80-0000-domain.tld
    Last edited: Oct 1, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, you are right, there is no official php-fpm support for centos 6.5, we implemented that only for the recommended Distributions Debian and Ubuntu. But normally it should work on Centos as well.

    I'am not quite sure why your apache tries to open this as a file. This is just a virtual placeholder for the fpm connection.

    Did you run the ispconfig update script with reconfigure services again?
    Is the php-fpm daemon running (check with netstat and ps).
  5. non7top

    non7top New Member

  6. non7top

    non7top New Member

    Well, I did a test install on Centos7 and it worked out of the box, well, except for FS#3717, which is fixable. Apparently it's httpd24.

Share This Page